Unable to run android after RC2


#1

Hello,
I use the module: ng2-inline-svg for SVG, after i update my version from ionic 2.0.0-rc.1 to ionic 2.0.0-rc.2
I get this error:

[10:23:40]  Error: Error at E:/projekte/starmovie-app/.tmp/components/px-icon/px-icon.ngfactory.ts:107:36 
[10:23:40]  Module ''*'' has no exported member 'Wrapper_InlineSVGDirective'. 
[10:23:40]  ngc failed 
[10:23:40]  ionic-app-script task: "build" 
[10:23:40]  Error: Error 

it look likes the is a problem by generating inline-svg.directive.ngfactory

Any idea where the problem could be?


#2

What version of @ionic/app-scripts do you have in your package.json?

This is probably an issue with app-scripts 0.0.36. I just gave it a shot with app-scripts 0.0.39 and it works without a problem


#3

checked our tutorial app:

it works without any issues on android 5.1


#4

I have the version "@ionic/app-scripts": "0.0.39", in my package.json and it is still not working. Before i made the update to RC2, i had the version ``"@ionic/app-scripts": "0.0.36",and it worked.


#5

Did you npm install?
What does ionic info show?


#6

yes i did npm install , ionic info shows:

Cordova CLI: 6.4.0
Ionic Framework Version: 2.0.0-rc.2
Ionic CLI Version: 2.1.4
Ionic App Lib Version: 2.1.2
Ionic App Scripts Version: 0.0.39
OS: Windows 7 SP1
Node Version: v6.9.1

#7

I think I can narrow the problem:

I keep receiving the following invalid error when I try to install zone.js:
Command: npm install
±- typescript@2.0.3
`-- UNMET PEER DEPENDENCY zone.js@0.6.26

npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@^1.0.0 (node_modules\chokidar\node_modules\fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.0.15: wanted {“os”:“darwin”,“arch”:“any”} (
current: {“os”:“win32”,“arch”:“x64”})
npm WARN angularfire2@2.0.0-beta.6 requires a peer of @types/jasmine@^2.5.36 but none was installed.
npm WARN ionic-angular@2.0.0-rc.2 requires a peer of zone.js@0.6.21 but none was installed.

I have tried everything from removing zone.js and doing an npm install with my package.json (zone.js version ~0.6.17 to zone.js version ~0.6.25) and even putting zone.js : “*” which then installs 0.6.26 and still shows UNMET PEER DEPENDENCY.


#8

First thing, make sure your angular, zone and rxjs packages match what we have for our app base.

As for your original error, check to make sure you have an updated version of ng2-inline-svg.
It seems that the error is in your px-icon template.


#9

I have changed my file that it looks like the example: package.json but now i get this error in:ionic serve

rollup failed: Could not resolve ‘./app.module’ from E:…\src\app\main.dev.ts