Ui-sref not changing states on android device


#1

I am having an odd issue with my ui-sref links. The links work as intended when running the app within the browser. However, the ui-sref links do not change states when running the app on my android device (version 4.4). I have even tried $state.go within an ng-click function and I got the same result. It works within the browser, but not the actual device. I have inspected the elements on the device and I can see the activate class toggling on the a tag elements when I touch then, but nothing happens. What I have noticed is that the only ui-sref or $state.go state transitions that work on the device are not within an abstract view (login, signup page). I’m certain that this has something to do with it. It seems that after transitioning from one of these views it makes it to the first child state of the abstract state. After that it will not transition to any other state when clicking the links. I have also changed the state that the login page goes to and it is the same case. It will go to that specified state and thats it.

Heres an example of one of my links:

<a  class="item item-icon-right" ui-sref="app.show-details({showId: show.id, showIndex: $index})">...</a>

Also here is an example of the state within the config

$stateProvider

.state('app', {
  abstract: true,
  url: '/app',
  templateUrl: 'mainMenu.html',
  controller: 'MainCtrl'
})
.state('app.show-details', {
  url: '/show-details/:showId/:showIndex',
  views: {
    'mainContent': {
      templateUrl: 'template/show-details.html',
      controller: 'ShowsCtrl'
    }
  }
});

This is just a snippet of my states just to get an idea of how they are setup. Maybe I am missing something. I have been looking into this issue for quite some time. I’d appreciate anyones help.


#2

Nevermind. It appears that ng-material was interfering with the ui-sref links. I do not know specifically how, but I have removed it from my app and everything is fine. Luckily, I can use another alternative for smooth animations with the UI beside ng-material. I will still look into this to find out how it has interfered with my links.