Typescript Error


#1

I trying to implement google auth in my app. I need it works in browser. So, I installed:

npm install --save @types/gapi
npm install --save @types/gapi.auth2

There is two warnings:

npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@^1.0.0 (node_modules\chokidar\node_modules\fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.0.15: wanted {“os”:“darwin”,“arch”:“any”} (current: {“os”:“win32”,“arch”:“x64”})

in node_modules folder I have gapi and gapi.auth2 folders
but I have typescript error: Cannot find name ‘gapi’, transpile failed

I installed

npm install typings -g
typings install dt~gapi --global --save
typings install dt~gapi.auth2 --global --save

Still have the same error: Cannot find name ‘gapi’, transpile failed

my code:

    auth2: any;

    login() {
          gapi.load('auth2', () => {
              this.auth2 = gapi.auth2.init({
                 client_id: 'xxxxxxxxx.apps.googleusercontent.com',
                 scope: 'https://www.googleapis.com/auth/userinfo.email'
              });
            });
          };

my package.json:

@angular/core”: “2.2.1”,
“ionic-angular”: “2.0.0-rc.4”,
“ionic-native”: “2.2.11”,
“rxjs”: “5.0.0-beta.12”,
“typescript”: “2.0.9”


#2

Solved, thanks to http://stackoverflow.com/users/4386952/daniel-rosenwasser.

The current declarations for gapi and for gapi.auth2 are global declarations.

They might not be automatically with @types because looking into node_modules either requires an explicit import or adding your libraries to the types field in your tsconfig.json.

So try fixing up the following types field to your compilerOptions:

"compilerOptions": {
     "types": ["gapi", "gapi.auth2"]
}