Typescript can't find the 'moment' package

I had the project working with js, then i started a new typescript project and copy the configs to mine, i have the moment package installed but the compilator complains that can’t find the moment package.

I tried to install and import inside the new typescript project just to ensure it isn’t my bad when copying the configs and happens the same, why if i had it working with the js project? i think it’s the same with D3 data visualization package, had it working and now it doesn’t, help?

Update, it’s the linter, the code still works, it’s just the linter that can’t detect the packages, that’s heavily missleading, posted an issue so that this can be fixed soon.

@luchillo17 having now tried both approaches, would you recommend TypeScript? I’ve developed my two Ionic 2 apps with js so far but was thinking of trying to convert them to ts seeing as the Angular team seem to be highly recommending we work with ts.

What are your thoughts? What code editor do you use (I’m using Atom at the moment)

Typescript is great, the issue is that moment is a third party library thus i should have installed the Typescript definition for moment, if you start a new project, the intelisense support is a great tool in development, tough i work in sublime 3 so idk if there is a plugin for Atom, but if already have a project, don’t bother with the refactor until you know the code won’t need to change a lot, the switch to typescript could need some amount of time that you don’t have due to date limits or such.

Here’s the closed issue i made: