TypeError: env.runcmd is not a function


#1

PS C:\Users\ramee\ionicapp\App Source Code> Ionic cordova build android --prod
Running app-scripts build: --build --prod --iscordovaserve --nobrowser

[21:25:47] build prod started …
[21:25:47] clean started …
[21:25:47] clean finished in 29 ms
[21:25:47] copy started …
[21:25:48] deeplinks started …
[21:25:50] deeplinks finished in 1.84 s
[21:25:50] ngc started …
[21:27:24] ngc finished in 94.51 s
[21:27:24] preprocess started …
[21:27:24] preprocess finished in 4 ms
[21:27:24] webpack started …
[21:27:27] copy finished in 100.16 s
[21:36:12] webpack finished in 527.46 s
[21:36:12] uglify started …
[21:36:12] sass started …
Without from option PostCSS could generate wrong source map and will not find Browserslist config. Set it to CSS file path or to undefined to prevent this warning.
[21:36:29] sass finished in 16.98 s
[21:36:29] cleancss started …
[21:36:41] cleancss finished in 12.44 s
[21:45:40] uglify finished in 568.40 s
[21:45:40] postprocess started …
[21:45:40] postprocess finished in 80 ms
[21:45:40] lint started …
[21:45:40] build prod finished in 1193.70 s
[WARN] Error occurred during command execution from a CLI plugin (@ionic/cli-plugin-cordova). Your plugins may be out of date.
TypeError: env.runcmd is not a function
PS C:\Users\ramee\ionicapp\App Source Code> ionic info
? The Ionic CLI has an update available (3.2.0 => 4.2.1)! Would you like to install it? No
[OK] Not automatically updating your CLI. You can update manually:

 npm install -g ionic@latest

global packages:

@ionic/cli-utils : 1.2.0
Cordova CLI      : 8.1.2 (cordova-lib@8.1.1)
Ionic CLI        : 3.2.0

local packages:

@ionic/app-scripts : 3.1.8
Cordova Platforms  : android 6.3.0
Ionic Framework    : ionic-angular 3.9.2

System:

Node       : v8.12.0
OS         : Windows 10
Xcode      : not installed
ios-deploy : not installed
ios-sim    : not installed

PS C:\Users\ramee\ionicapp\App Source Code>

any idea what i missing …I know all the version are old… its as per the source code provider instruction …now he is nor responding can anyone have any idea what i did wrong


#2

I would suggest saying “yes” to that CLI upgrade.


#3

downgrade @ionic/cli-plugin-cordova its works now