Too many packages deprecated, NPM warnings and permission errors


#1

Hello,
Newbie here.

When i try to create a new ionic project with something like -
ionic start FirstApp tabs

I get a lot of NPM warning and deprecated warnings. And a lot of error and permission warnings… Is there a way i can understand what is going on, and how to fix all this? Sorry for the silly question.

OS - Ubuntu 16.04 LTS


Npm WARN deprecated minimatch@2.0.10: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
#2

I appear to be getting the same kind of warning messages (on Mac OS 10.12.1)

I will keep searching to see if I can find anything in terms of someone who has encountered (and remedied!) this.

If I do, I’ll come back here and post details.


#3

I found another, slightly more populated, thread elsewhere on this forum at …

I hope you don’t mind @steveprateek but I’ve been putting anything else I’ve found out into that thread.

In truth, I don’t think I’ve turned up much of any use to anyone in the position we’re in, as yet. Sorry.


#4

That’s ok i appreciate your reply. It’s weird why such things would happen, and it just makes me feel that node and javascript development is just changing SO fast that the updates are literally a mess.

Well i still have to go a long way to make a proper judgement with javascript development, but seriously man, starting to learn something that updates so frequent is really annoying.