The config.xml file is missing a content element


#1

Hello all. I have an issue in my ionic project. Every time when I run it , it gives me error I,e " the config.xml file is missing a content element that defines the start page. What is this error and how to solve this. Please help me as soon as possible. I am using vs 2015 cordova. With angular js.please help me.


#2

So you are using Ionic v1?

Post your ionic info output please.


#3

how i get ionic info ? can u please replay me !


#4

is there ant person who solve my issue. please help me ?


#5

You took a photo of your screen…???

Just send the config.xml as text


#6

check this ?


#7

That would be a screenshot, not text.

To get ionic info, just run ionic info on the command line in your project folder.


#8

Hello there after getting ionic info. i am getting a response which i uploaded. please check the pic.

Please check


#10

Something is strange with your project. Open the package.json file and copy the content into an answer here. Format it as code so it is readable.


#11
 { 
  "//":"Changes to this file will be overwritten",

  "name": "copay",
  "description": "A Secure Bitcoin Wallet",
  "author": "BitPay",
  "version": "3.8.2",
  "keywords": [
    "bitcoin",
    "wallet",
    "bitpay",
    "copay",
    "multisignature",
    "bitcore"
  ],
  "main": "www/index.html",
  "title": "Copay",
  "window": {
    "title": "Copay - Copay Bitcoin Wallet",
    "icon": "www/img/app/icon.png",
    "toolbar": false,
    "show": true,
    "visible": true,
    "resizable": true,
    "frame": true,
    "width": 400,
    "height": 650,
    "min_width": 400,
    "max_width": 800,
    "min_height": 650,
    "position": "center",
    "fullscreen": false
  },
  "webkit": {
    "page-cache": false,
    "java": false,
    "plugin": false
  },
  "dom_storage_quota": 200,
  "id": "jid1-x7bV5evAaI1P9Q",
  "homepage": "https://copay.io",
  "license": "MIT",
  "repository": {
    "url": "git://github.com/bitpay/copay.git",
    "type": "git"
  },
  "bugs": {
    "url": "https://github.com/bitpay/copay/issues"
  },
  "engines": {
   "node": "6",
   "npm": "3"
  },
  "dependencies": {
    "adm-zip": "^0.4.7",
    "angular": "1.4.6",
    "angular-mocks": "1.4.10",
    "bezier-easing": "^2.0.3",
    "bhttp": "1.2.1",
    "bitauth": "^0.2.1",
    "bitcore-wallet-client": "6.2.1",
    "bower": "^1.7.9",
    "cordova-android": "5.1.1",
    "cordova-custom-config": "^3.0.5",
    "cordova-plugin-qrscanner": "^2.5.0",
    "coveralls": "^2.11.9",
    "express": "^4.11.2",
    "fs": "0.0.2",
    "fs-extra": "^0.30.0",
    "grunt-angular-gettext": "^2.2.3",
    "grunt-browserify": "^5.0.0",
    "grunt-cli": "^1.2.0",
    "grunt-contrib-compress": "^1.3.0",
    "grunt-contrib-concat": "^1.0.1",
    "grunt-contrib-copy": "^1.0.0",
    "grunt-contrib-uglify": "^2.0.0",
    "grunt-contrib-watch": "^1.0.0",
    "grunt-exec": "^1.0.0",
    "grunt-nw-builder": "^2.0.3",
    "grunt-sass": "^1.2.0",
    "load-grunt-tasks": "^3.5.0",
    "shelljs": "^0.3.0"
  },
  "scripts": {
    "postinstall":            "bower install",
    "start":                  "npm run build:www && ionic serve --nolivereload --nogulp -s --address 0.0.0.0",
    "start:ios":              "npm run build:www && npm run build:ios && npm run open:ios",
    "start:android":          "npm run build:www && npm run build:android && npm run run:android",
    "start:windows":          "npm run build:www && npm run build:windows",
    "start:desktop":          "npm start",
    "watch":                  "grunt watch",
    "build:www":              "grunt",
    "build:www-release":      "grunt prod",
    "build:ios":              "cordova prepare ios && cordova build ios --debug",
    "build:android":          "cordova prepare android && cordova build android --debug",
    "build:windows":          "cordova prepare windows && cordova build windows -- --arch=\"ARM\"",
    "build:ios-release":      "cordova prepare ios && cordova build ios --release",
    "build:android-release":  "cordova prepare android && cordova build android --release",
    "build:windows-release":  "cordova prepare windows && cordova build windows --release --arch=\"ARM\"",
    "build:desktop":          "grunt desktop",
    "build:osx":            "grunt osx",
    "open:ios":               "open platforms/ios/*.xcodeproj",
    "open:android":           "open -a open -a /Applications/Android\\ Studio.app platforms/android",
    "final:www":              "npm run build:www-release",
    "final:ios":              "npm run final:www && npm run build:ios-release && npm run open:ios",
    "final:android":          "npm run final:www && npm run build:android-release && npm run sign:android && npm run run:android-release",
    "final:windows":          "npm run final:www && npm run build:windows-release",
    "final:desktop":          "npm run build:desktop && npm run build:osx",
    "run:android":            "cordova run android --device",
    "run:android-release":            "cordova run android --device --release",
    "log:android":            "adb logcat | grep chromium",
    "sign:android":           "rm -f platforms/android/build/outputs/apk/android-release-signed-aligned.apk; jarsigner -verbose -sigalg SHA1withRSA -digestalg SHA1 -keystore ../copay.keystore -signedjar platforms/android/build/outputs/apk/android-release-signed.apk  platforms/android/build/outputs/apk/android-release-unsigned.apk copay_play && $ANDROID_HOME/build-tools/26.0.1/zipalign -v 4 platforms/android/build/outputs/apk/android-release-signed.apk platforms/android/build/outputs/apk/android-release-signed-aligned.apk",
    "apply:copay":            "npm i fs-extra && cd app-template && node apply.js copay && npm i && cordova prepare",
    "apply:bitpay":           "npm i fs-extra && cd app-template && node apply.js bitpay && npm i && cordova prepare",
    "test":                   "echo \"no package tests configured\"",
    "clean":                  "trash platforms && trash plugins && cordova prepare",
    "unstage-package":        "git reset package.json",
    "clean-all":              "git clean -dfx"
  },
  "devDependencies": {
    "cordova": "^6.3.1",
    "grunt": "^1.0.1",
    "ionic": "^3.6.0",
    "trash-cli": "^1.4.0",
    "lodash": "^4.17.4",
    "pre-commit": "^1.1.3"
  },
  "pre-commit": "unstage-package"
}


#12

Where did you get that code from? Is this a downloaded project?


#13

yess it is downloaded from github.


#14

Would you be interested in sharing the link so we might be able to help you debug your problem?


#15

#16

https://github.com/bitpay/copay/blob/master/package.json is totally different from what you posted.


#17

The config.xml file doesn’t look to be an issue.

Have you gone through the stock instructions on the git readme as opposed to Visual Studio?


#18

after download this project from github, and open it in VS 2015 , u will get same package.json file which i posted earlier. but my issue has not resolved yet. please help me.


#19

I tried and failed to make this run. Just too many dependencies.

Speak to the author.


#20

i cleared all the dependencies , but when i run this " it reported me that " the config.xml file is missing a content element that defines the start page". i donot know how to sort this issue ?


#21

hello every one i have a problem …my ionic project do not have the config.xml file how can i add one please it is quit urgent thanks
when i run

ionic cordova run android --device

i have the error

Error: ENOENT: no such file or directory, open '/home/larissa/maibeta/myapplication/config.xml'

i created a new project saying yes to the ''cordova ‘’ question on ionic start, i copied the config.xml file the new project to the other one.
i opened the config.xml in the first project and changed the name.
when running the project i had


Error: Failed to transpile program
    at new BuildError (/home/larissa/maibeta/myapplication/node_modules/@ionic/app-scripts/dist/util/errors.js:16:28)
    at /home/larissa/maibeta/myapplication/node_modules/@ionic/app-scripts/dist/transpile.js:159:20
    at new Promise (<anonymous>)
    at transpileWorker (/home/larissa/maibeta/myapplication/node_modules/@ionic/app-scripts/dist/transpile.js:107:12)
    at Object.transpile (/home/larissa/maibeta/myapplication/node_modules/@ionic/app-scripts/dist/transpile.js:64:12)
    at /home/larissa/maibeta/myapplication/node_modules/@ionic/app-scripts/dist/build.js:109:82
    at <anonymous>

please help