The application does not open on device (crash before splashscreen)


I am working on an application that is currently on the store.

However, working on an update, I encounter a problem.

Indeed, the application works perfectly on the ionic serve but does not open at all (not even the splash screen) when I put it on my device.

I first wondered if it came from a code problem in the update, however, even when trying with the old version, it does not open anymore …

(The application that is on the store still works correctly but when i do ionic cordova run android is working but the application does not open)

Where can it come from? It blocks me a lot …

thank you very much

you mean not opening after app install on device?

Yes after app is install on device

And do you have e.g. white screen or something else? Some error in console? Or simply app do not run at all - you can still see home screen of phone?

Simply add do not run at all, yes i can still see home screen of phone it just show like 1 sec the statusbar up changing but nothing else …

I have got the same problem . After ionic cli update from 4.2.0 to 4.2.1 . When i build app on device is not opening. When i install clean project after build app work after that i install some plugin ( from native plugin list lika admob or social sharing ) after build app crash on start. There is the way to debbug why app is crashing ?


You can watch logs with chrome://inspect and with adb logcat :


Thanks for helping me but i can’t use chrome://inspect, application does not open on device so, nothing show in chrome://inspect …

Same… after ionic cli update…

I tried everything … changed the version … all update ect … the application does not launch more on the device … it blocks me enormously …

Seems that problem is cordova-plugin-admobpro.
I removed this plugin and app is opening after build.
This is what I did :

ionic cordova plugin rm cordova-plugin-admobpro
ionic cordova platform rm android
ionic cordova platform add android@7.0.0
ionic cordova run android --device

I builded app and app was opened without problem after that i add cordova-plugin-admobpro and app has crashed

I don’t use admobpro…:sleepy:

Did you add or update any package since the old version?

I had this kind of issue in the past on a dependence conflict in / platform / android /

2 plugin asked for 2 different version of a library and the older version was in the
An other time the included the same library 2 times with differents version.

Did you try to remove platforms folders and reinstall them.

No, i just update some, but i downgrade like before for try and it’s the same result… I try twice remove android and add android but same result…

The adb logcat command should show you the java exception which cause the issue.

With no more informations or logs…
An other way to find where it come from is to start a blank project and add a group of dependancies and test group by group. After configs and dependancies added if the issue is not in the dependancies try to add your code again group by group.

I think i found my error with adb logcat !! Capture

try this…add in config.xml

<preference name="loadUrlTimeoutValue" value="60000" />

not working … :tired_face:

showing any error when you open app on device?

nothing … the app close instant !

with adb logcat it show this, i dont know if this my error … Capture