Text-overflow ellipsis not working

Hi guys,

I’ve overwritten this style, to remove the text-overflow ellipsis from the rendered text

.item, .item h1, .item h2, .item h3, .item h4, .item h5, .item h6, .item p, .item-content, .item-content h1, .item-content h2, .item-content h3, .item-content h4, .item-content h5, .item-content h6, .item-content p {
    text-overflow: initial;
    white-space: normal;

But it doesn’t seem to be working, as it can be seen on the screenshot above. Any ideas ?


.item, .item h1, .item h2, .item h3, .item h4, .item h5, .item h6, .item p, .item-content, .item-content h1, .item-content h2, .item-content h3, .item-content h4, .item-content h5, .item-content h6, .item-         content p {
    text-overflow: initial !important;
    white-space: normal !important;
    overflow:visible !important;

When overriding any CSS declared by Ionic use the important flag :smile:

you can do it without !important, but make sure that you include your css after ionic’s

That aswell :blush: , but I prefer not to include it after and use important flags as that’s how many people have set up their projects.

The problem with important flags is that it is getting very difficult to overwrite them later if you need exceptions. It becomes a specificity mess :smile:

Thanks for the help but the issue was/is on the data itself. I’m already getting it trimmed

Today I learned: Check your data before making a post

As for the discussion here, don’t like to use the !important because like @yurinondual mentioned, it will get messy in the future. And in this case I don’t need to do it

Thanks anyway