[TABS] Bad performance ios

I created an application using the tabs template and modified the bottom bar by changing the style.
I have reduced the size of the icons, exactly:

$ tabs-ios-tab-icon-size: 28px;

In android the application is very fluid, very fast, very good.

The problem is in IOS when changing between tabs fails. Sometimes it does not detect the pulsation in the icon, sometimes it takes a lot of time.
I have seen is that if you click on the top of the icon it works very well, but if you click on the bottom it does not work.

I have not seen anything like it in the forum and I’m intrigued that it only happens in ios.
iPhone has a screen that comes from below, is it possible that 2 things are relationated?

Is it possible that the event is captured by the device and ionic does not detect the tap?

Any ideas?

I had similar speed issue with Ionic’s ion-segment.
I created my own tab using Angular 5 directive and CSS3 and now it’s working so fast… I think this is the best way.

Check this thread:


Angular 5 tab is error free and faster…and you can style it by yourself using CSS3.

Thanks for the reply but I think the case is different.

The problem is that sometimes it does not detect the taps in the icons, possibly due to some conflict with the IOS event that shows a menu from below.

I take a look on the post and I find the links very interesting. Although I do not know what part of the post is what you propose me.

Anyway, if we have chosen to use ionic we should use the components that ionic provides us. I do not think it is a good solution to create our components when they already exist.

Could you take a look at this issue? https://github.com/mapsplugin/cordova-plugin-googlemaps/issues/1919

I think you described the same behaviour as in the gif posted on this issue.
Could you confirm that?
If so, are you using the google maps plugin?

1 Like

yes, yes and absolutely yes !!
That is exactly my problem.
I am also using the plugin cordova-plugin-googlemaps.
In my case the map is not loaded until you access the map in a subpage.

Have you found any solution?

Thanks a lot!

PD: I read the link again and someone has shown that the application works well on iPhone X. It comes to my mind that the problem is causing the safe-area that has been included for the iPhoneX. That would explain why the rest of the iPhone does not work properly. What do you think abut it???

Actually, I am the one who opened this issue.
There, I shared a demo project that reproduces the issue.
However, the author of the google maps plugin cannot reproduce it, even with my demo project.

Someone also noticed that removing either the google maps OR statusbar plugin solves the issue.
The safe-area may also be involved here, I am not sure.

Could you check if you can reproduce the issue with my demo project?
Let me know, maybe you can help us figure out what is wrong.

The author of the plugin just fixed the issue! You can try there the patch commit.

1 Like

Works for you?

Yesterday I tried the solution that they proposed you two weeks ago. Trying the multiple_maps branch. But the problem persisted.
I did not have time to test your test project.

Unfortunately, I just tried the new fix and it does not solve my problem.
I do not know where the problem is, I am unable to find it.
The nightmare continues…

I have finally solved the problem, ‘only’ that I had to remove the status bar plugin.
Thank you for all!

I’m going to open a issue to statusbar people.