Swiper disabled in production mode, Ionic-v4

This problem appears in posts for ionic-v3 but I didn’t see any resolution:

Swiper does not work

I’m using Ionic v4.

The Swiper (ion-slides) stops working in production mode. It simply shows the first slide, and gives no functionality (does not even show the pager dots).

Any help to resolve this would be great else I can’t use production mode at all.

bump… anyone can help on this one? its rather important.

Not an answer but often I noticed that such stuffs happen is because something else is breaking and throwing an error and for that reason the swiper load isn’t processed

What’s the stacktrace of the error ? Did you debug your problem with the Google Chrome or Safari console debugger ?

I get this in the Firefox console:

Unhandled Promise rejection: c.data is not a function ; Zone: <root> ; Task: Promise.then ; Value: TypeError: "c.data is not a function"

    t http://localhost/www/6.98e445a1e55cc61bbcd9.js:1 initSwiper

Actually some more digging and it seems to be a very recent issue that has been fixed in the master branch:
Issue 17034

In RC.1, which version are you using of Ionic Angular?

Do you face the error only in Firefox?

yeah it was RC.1, when I used dev then it worked, seems like it is fixed, as well as some other minor bugs I noticed before that are now fixed.

No it was also on android device

Ok then it’s solved, I mean the last version of ionic angular is 4.0.2 so all good right?