Splashscreen not building


#1

Splash screen is not being built on device with ionic run android.

Steps I have taken:

  • delete all resources and generate new ones with ionic resources command
  • check all routes in config.xml, they are correct
  • remove/add android platform

This is occurring after I have cloned my original project which did show the icon. But now on the new copy, the icon refuses to built in the www/ file.

Anybody with any other options?

Ionic Framework Version: 2.0.0-rc.3                                                                                                     
Ionic CLI Version: 2.1.13                                                                                                               
Ionic App Lib Version: 2.1.7                                                                                                            
Ionic App Scripts Version: 0.0.45                                                                                                       
ios-deploy version: Not installed                                                                                                       
ios-sim version: Not installed                                                                                                          
OS: OS X El Capitan                                                                                                                     
Node Version: v6.7.0                                                                                                                    
Xcode version: Not installed ```

#2

Seems to be an active issue/bug https://github.com/driftyco/ionic-cli/issues/1166


#3

Thanks for that @0x1AD2. After I posted, I went ahead and dragged the entire res/ folder generated by ionic resources into my www/ folder, and the icon seems to be fine now. The splash screen still does not render though…


#4

I fixed it a couple of weeks ago for a project of mine, not sure what it was exactly but I updated the Android version of Cordova like https://github.com/driftyco/ionic-cli/issues/1166#issuecomment-267359848 did. I’m going to try it again with a new project, will update.


#5

Just tried it and it worked (used a new RC5 project).
Execute the following commands:

$ cordova platform update android@6.1.0
$ ionic resources android


Cordova CLI: 6.4.0
Ionic Framework Version: 2.0.0-rc.5
Ionic CLI Version: 2.1.18
Ionic App Lib Version: 2.1.9
Ionic App Scripts Version: 1.0.0
ios-deploy version: 1.9.0
ios-sim version: 5.0.11
OS: macOS Sierra
Node Version: v6.9.1
Xcode version: Xcode 8.2.1 Build version 8C1002