[solved] Xcode "build->archive" does not create archive in organizer

I have two apps built in ionic. One has been submitted to the app store just fine.
I’m trying to build the other app in a similar fashion and xcode says all is well. However, when I “build”->“archive”, no archive is created in the organizer so I can’t submit the app.

Has anyone has the same issue before or has any idea what can be wrong? There are no errors, the build goes through, there’s just no archive to submit in the organizer.

I see that my working app has the option to run it on a device, where here, I can’t select that option, I can only select “My Mac 64-bit”?

SOLVED: if anyone wonders, for some reason there was no executable selected in my running scheme. Just select “edit scheme” next to your run button and select the correct executable. Found it by comparing all settings between two apps.

@jorre, thanks a lot for the answer, I had the same issue and got it resolved thanks to your answer. Thanks again.

I posted the same question in StackOverflow , If you dont mind you could post an answer to my question and I’ll accept it (so that someone reading SO will find it useful)

thanks again , cheers

your solution saved my bu**
Thank you!! was pulling the few hairs remaining. (btw… im bald… lol)