[Solved] Text Input cannot be edited


#1

Hi,

I have several “input text” elements on different pages and I when I tap on it I cannot position the cursor in the position where I tap, the cursor always goes to the end of the text.

As a result, the text of the input cannot be edited, you can only start from the end of the text and delete.

The html we’re using is very similar to the one in the example http://ionicframework.com/docs/components/#forms-placeholder-labels

It happens both on Android and iOS, but it works perfectly on the browser.

Any ideas what might be happening?

Thanks!


#2

Hey can you post the code your using? A codepen maybe? This way we can narrow down what the problem is


#3

Hi Mike,

I just created a new project with “ionic start myApp blank” and when running it on my phone I found the same thing, I cannot edit the text inputs in the “Adopt” tab.

I’m using:
Ionic, v1.0.0-beta.1
Android 4.4.2
Google Nexus 5
(although we have tried other phones and Android versions and saw the same thing)

Thanks!


#4

Whats the mark up look like? Give this a try and let me know if this works

<div class="list">
  <label class="item item-input">
    <input type="text" placeholder="First Name">
  </label>
  <label class="item item-input">
    <input type="text" placeholder="Last Name">
  </label>
  <label class="item item-input">
    <textarea placeholder="Comments"></textarea>
  </label>
</div>

#5

The markup on the blank project is a bit different, but I also tried your markup and the same thing happens, when tapping on the text input or the textarea, the cursor always goes to the end of the text, you cannot edit it.


#6

Hmm, can you post your actual markup? I will create a new project with that and see what the issue is


#7

I just created a new project using the starter project. Then I changed the form to try your markup, but it didn’t work either.

Check it out here, you can see the original markup commented and the one you suggested:

As I said, it works on the browser on the computer, but not on Android, you cannot edit the text inputs or textarea.

Thanks!


#8

It’s the same issue as described here: Move cursor in between text on input fields #1068


#9

@inaki So I downloaded your github project and ran it through the simulator. I was able to position the text cursor where I needed to be.

See this screen cast:

Is this what you are unable to do?


#10

@mhartington the issue was this one. But it’s already fixed :smile:

Thanks!


#11

Awesome, glad to know its been fixed. I’m going to mark this as solved.