[solved] Development server liveReload not working [MacOS Catalina/zsh]

When I use the development server (ionic serve) in my old dev config, it no longer detects code changes. I also see an additional line referencing webpack-dev-server which I didn’t notice before:

 % ionic serve --no-open
> ng run app:serve --host=localhost --port=8100
[ng] ℹ 「wds」: Project is running at http://localhost:8100/webpack-dev-server/
[ng] ℹ 「wds」: webpack output is served from /
[ng] ℹ 「wds」: 404s will fallback to //index.html

Here is a snapshot of my ionic info:

% ionic info


   Ionic CLI                     : 6.12.0 (/Users/m/.nvm/versions/node/v12.16.1/lib/node_modules/@ionic/cli)
   Ionic Framework               : @ionic/angular 5.0.0
   @angular-devkit/build-angular : 0.803.29
   @angular-devkit/schematics    : 8.2.2
   @angular/cli                  : 8.3.25
   @ionic/angular-toolkit        : 2.1.2


   Capacitor CLI   : 1.5.0
   @capacitor/core : 1.5.0


   cordova-res : not installed
   native-run  : not installed


   NodeJS : v12.16.1 (/Users/m/.nvm/versions/node/v12.16.1/bin/node)
   npm    : 6.14.8
   OS     : macOS Catalina

The only major change I can think of is a recent upgrade to MacOS Catalina and related switch to /bin/zsh. Any suggestions?

I just confirmed that this has something to do with my recent upgrade to MacOS Catalina and/or zsh.

I tried the latest ionic-cli on an older MacOS with HighSierra and liveReload works just fine in a new tabs project.

Furthermore, I create a new nodejs install with nvm use lts/dubnium and repeated a complete new install of ionic-cli plus tabs project on the MacOS Catalina and the problem persists.

The problem was because of an /etc/synthetic.conf link to make the MacOS root folder folder.