[SOLVED] Can't enter data into input[number] field


#1

I’m using a simple input number field in my app and on iPhone I can’t enter any numbers in it. In the browser I can input numbers, but not on the actual mobile device.

Here is my input.

<input type="number" ng-model="filter.minRate" min="0">

I have downloaded the latest nightly build (#4d5e39d333) and still no luck.


#2

Can you put together a demo or codepen? I’ll copy it over to a project and test it on an actual device


#3

Thanks! Here it is: http://codepen.io/anon/pen/dALap


#4

Hmm, I was able to throw in the simulator and it worked fine.


#5

Oh I forgot, also my input was in a modal. Maybe that’s why?


#6

Maybe, Ill give it a try and let you know


#7

So I grabbed a copy of the modal demo from the codepen showcase and added your input into the modal.

I was tapping around a bit but i was able to enter data into it


#8

Alright. It’s probably something on my side then. Thanks!


#9

Ok, so after a few days trying to figure out what was happening, I noticed one difference between your example and mine: my input was near the bottom of the screen. This in turn would cause the the view to re-center on the input after the keyboard slides up and would cause the input to not work. However, I managed to make it work by pressing the < and > buttons to go to previous/next inputs.

Here is a video of what it looks like in action:

Also, another interesting thing that happens to my last input:

** I’ve also updated to the latest nightly version (1.0.0-beta.1-nightly-1837).


#10

Hmm, can you try to reference the CDN version of ionic? The latest build is beta.3-1990

<link href="http://code.ionicframework.com/nightly/css/ionic.min.css" rel="stylesheet">
<script src="http://code.ionicframework.com/nightly/js/ionic.bundle.js"></script>

#11

Wow now it works. Thanks!

What I was using was I would pull the latest version from https://github.com/driftyco/ionic-bower and have to import all the scripts in the head. I will be using ionic.bundle.js from now on. :smile: