Server Error with Crosswalk when running ionic run android


I encountered an error when trying to run ionic run android. The message I got is:

FAILURE: Build failed with an exception.

* What went wrong:
A problem occurred configuring root project 'android'.
> Could not resolve all dependencies for configuration ':_armv7DebugApkCopy'.
   > Could not resolve org.xwalk:xwalk_core_library:23+.
     Required by:
         project :
      > Could not resolve org.xwalk:xwalk_core_library:23+.
         > Failed to list versions for org.xwalk:xwalk_core_library.
            > Unable to load Maven meta-data from
               > Could not GET ''. Received status code 503 from server: Service Unavailable

Is the server down?  How can I resolve this issue?  The command was running fine until yesterday.
1 Like

This happened to me last year when the server went down. There wasn’t really anything I could do until it came back up.

1 Like

the same here, let’s watch and see what’s next.

same error.
Looks like it is in maintenance phase right now.
if any one found solution kindly share.

I had the same matter. How to solve this? caused build android with errors!

same problem for me!

The server seems to be down. So till the servers are back online, you can ask Gradle to use the local copy of Crosswalk.

I was having the same issue from last one hour. The following solution worked for me.

Open platforms\android\cordova-plugin-crosswalk-webview\*-xwalk.gradle file in your project directory, where * is your project name.

Look for the section -

dependencies {
    compile xwalkSpec

Replace it with your exact Crosswalk version which you find in Chrome Developer Tools by typing window.navigator.userAgent in your Developer Tools console.

So your final data would look something like this -

dependencies {
    compile 'org.xwalk:xwalk_core_library:23.53.589.4'

Thank you so much hemantv!
That’s why I love about our ionic community. People helps each other!

Thank you for this hemantv.

We can follow the status of the issue here:

1 Like

You really saved my day…
Have a good day~

seems to be the way to go
thank you

I cannot find my Crosswalk version. Running the command in Dev Tools gives following:


"Mozilla/5.0 (Linux; Android 5.1.1; Nexus 6 Build/LYZ28E) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/59.0.3071.115 Mobile Safari/537.36"

You can try this alternative method to get the version of Crosswalk, rest of the steps are same.

You can also add the following to the config.xml file

<preference name="xwalkVersion" value="xwalk_core_library:23.53.589.4" />
instead of modifying the plugin code.

You can change the library version as necessary.


Thank you for this @hemantv

Official words from Crosswalk about this:

This solution solve my problem. Thanks a lot!