Safari can't see simulator, web inspector missing


#1

I’ve recently upgraded to High Sierra and XCode 9.3, iOS 11.3 (in simulators). The Safari develop menu no longer shows a running simulator to attach to. It use to be that I just had to relaunch Safari and all would be well.

I’ve also noticed that the “web inspector” switch in the simulated device (Safari > Advanced > Web Inspector) is missing! I am not able debug an iOS Cordova app in a simulator anymore.

Any idea what’s going on?

My env:

cli packages: (/usr/local/lib/node_modules)

@ionic/cli-utils  : 1.19.2
ionic (Ionic CLI) : 3.20.0

global packages:

cordova (Cordova CLI) : 7.1.0 

local packages:

@ionic/app-scripts : 3.1.8
Cordova Platforms  : android 6.3.0 ios 4.5.4
Ionic Framework    : ionic-angular 3.9.2

System:

Android SDK Tools : 26.1.1
ios-deploy        : 1.9.2 
ios-sim           : 6.1.2 
Node              : v7.4.0
npm               : 5.5.1 
OS                : macOS High Sierra
Xcode             : Xcode 9.3 Build version 9E145 

Environment Variables:

ANDROID_HOME : /Users/jasonw/Library/Android/sdk

Misc:

backend : pro

#2

Same problem here, no simulators shown.


#3

I read this issue and noticed I had the same problem. After looking for a bit I finally managed to restore the situation by disabling/enabling the the Web Inspector on my (real) iPhone

Settings -> Safari -> Advanced -> Web Inspector -> off and on again

#4

What I noticed is that the “Web Inspector” checkbox has gone missing from simulated devices. It’s present on real devices, but not the simulators.


#5

I edited my post, correct, I had the problem with my real device not simulated


#6

Is anyone seeing what I’m seeing. A missing web inspector switch in simulators. I can’t be sure if was there before or defaulted to on. All I know is that safari can it see the emulators no matter what I try. Arghh.

Jason


#7

Did you solve the problem? I’ve tried rebooting, launching Safari after the simulator. And where did the web inspector switch disappear to?

I’m totally stuck. I cannot debug simulators with Safari.


#8

I just solved the problem by installing the Safari Technology Preview for High Sierra. That version of Safari can see the simulator. WTF


#9

Yes, that solved the problem


#10

Glad I was able to find a solution. I’m surprised that so few people reported this. It was pretty serious problem to go without a solution.


#11

i also have this problem. web inspector is not available on ios 11.3 simulator.


#12

So yes unfortunately the issue is safari / iOS version dependent;/ Seems like in future this funcitonality will be “back” in the newest Safari but its not ye there…