Run iOS from CLI works fine, but error running in XCode

Yo! If I run the following from the terminal…

ionic cordova run ios --prod --address= --no-native-run -lc

it works fine and opens up on the iPhone, but when I run it from XCode, it doesn’t go beyond the splash screen, and gives these errors (among others)…

[NetworkInfo] Signal strength query returned error: Error Domain=NSPOSIXErrorDomain Code=13 “Permission denied”, descriptor: <CTServiceDescriptor 0x2825e8060, domain=1, instance=1>

HTTP load failed (error code: -999 [1:89])

Failed to load webpage with error: The operation couldn’t be completed. (NSURLErrorDomain error -999.)

Failed to load webpage with error: Could not connect to the server.

What gives?? How come it works fine via CLI, but not XCode? How can I determine what URL it’s trying to connect to? I was hoping to get it ready to submit to the app store, but with this issue, it might get rejected.

Any help would be appreciated. Thanks.

Any news here, same in my project now?