Refused to apply style from 'http://localhost:8100/build/main.css' because its MIME type ('text/html') is not a supported stylesheet MIME type, and strict MIME checking is enabled

Hello, Guys!!! I have a big problem. Yesterday I start to develop the app, all was fine. But today in the morning when I have entered “ionic serve” I get that issue and nothing helps me. I read about color issue but I have only basic colors in variable scss.

3 Likes

same problem here ,

I had a backup of my /build folder in /platforms/ios/www When I pasted that over my /build folder in /www everything worked fine again.

You need to have a look in your index.html file and look for . Like it says in the error message yours must be set to instead of .

2 Likes

is it solved … ???

I found the solution to fix it but don’t know the ultimate cause of this.
Solution ->
Just go to any of the .ts files like user.ts or app.ts and press ‘CTRL+S’.
Now it will automatically again build and serve your app and once build is finished ,your app will run fine.

You will have to do this each time you write fresh ‘ionic serve’ in terminal.
But not required if automatically build during development cycle on pressing ‘CTRL+S’.

15 Likes

That’s an interesting fix. As simple as Ctrl+S. Thanks!

works great, thanks …

i did this cmd- npm install @ionic/app-scripts@latest --save-dev
and after this cmd- ionic cordova platform add android
and after this cmd- npm install
This things work for me…try it

3 Likes

Most likely you uninstalled/removed a plugin.
What I did is to delete the node_modules folder.
Then run $ npm install
After so, I ran $ ionic serve

saving a .ts file works but if you stop and serve again the same error will arise.
i delete node_module and installed again, nothing changed, i’m getting that error.

please look at this issue

Couldn’t find a proper solution except moving src folder to a new created project.

Has someone found a solution to that ?

Try…!
CLOSE and REOPEN the IDE and try again with IONIC SERVE

1 Like

npm install @ionic/app-scripts@latest --save-dev
worked for me
thank you

Worked for me too! Thank you!

I still have a problem with that. I’m doing everything what you said in this topic and nothing working for me.

image

1 Like

Thanks, worked for me

Isn’t this weird? No explanation. I don’t expect anyone at Ionic will bother taking a look

That worked interestingly. However, is it a bug depending on ionic ?