RC4 latest Forms, not working on ionic

So I’ve installed Angular RC4 and ionic-angular beta 11.

Right now my ngModel is no longer bound to my Component.
I have a simple

<form #someId="ngForm">
                <ion-label stacked>{{'mobile' | translate | async}}</ion-label>
                <ion-input type="text" ([ngModel])="mobile" name="mobile" maxlength="10"></ion-input></ion-item>
...some button here

Form, but for some raisin (hehe raisin) I can’t get this value in my Component it’s always an empty string…

I also get the deprecated form message on load.

if I change




I get a “no value for accessor ‘’” error.

Well I see one problem if this is what your HTML looks like. It looks like you have missing end quotebon you ngForm. I would look at angular 2 Forms docs maybe you’d find the answer there. It looks like you using the the template driven method. I would also check yo typescript/JavaScriptto make sure you importing any form stuff from the Forms module and not the common module.

That quote is a typo, that’s no my structure.

Problem is that the docs are focussed on RC5, which we can’t use on ionic

Well the major change to forms in angular happened I believe it was rc2 or 3. I didn’t think that was much change form wise between rc4 and rc5. I wish I could be more help but I use the model driven form not the template driven and having no issues. I have even used ngModel in some places. I would really double check your form ports becausei know in beta 11 and ng rc4 they moved all the form stuff to @angulaer/forms.

I remember some things changed, I actually updated like 1 or 2 weeks ago, and was using forms 0.2.0 or such.

Now I’m on latests whilst it SHOULD JUST WERK, it doesn’t yet. But thanks maybe I’ll move to model driven I guess, they’re neater anyways.

I was just looking some code and it looks.like you ngModel should formName.mobile. obviously form name is the variable that you named the form as a whole.

You mean the conference app?

I tried that now, same result I’m probably missing something

Just noticed conference app is still on 0.2.0, Good job to me for using it as a reference