Printer is not working

Hi, I checked the forum for this issue and i found this post (Native "Printer" plugin not working) That’s exactly that happens to me but i cannot fix it :frowning:

It’s an Ionic 3 project.

If someone could please help me i’ll put here all info that i can. I can say that is a legacy project (I don’t know if legacy in programming has the same term that i wan to explain. Person A starts projects, and ME as Person B continues with project.)

Ionic:

Ionic CLI : 6.16.3 (/Users/samy/.nvm/versions/node/v11.9.0/lib/node_modules/@ionic/cli)
Ionic Framework : ionic-angular 3.9.2
@ionic/app-scripts : 3.2.3

Cordova:

Cordova CLI : 10.0.0
Cordova Platforms : 9.1
Cordova Plugins : cordova-plugin-ionic-keyboard 2.2.0, cordova-plugin-ionic-webview 2.5.2, (and 19 other plugins)

Utility:

cordova-res (update available: 0.15.3) : 0.6.0
native-run (update available: 1.4.0) : 1.3.0

System:

Android SDK Tools : 26.1.1 (/Users/samy/Library/Android/sdk)
NodeJS : v11.9.0 (/Users/samy/.nvm/versions/node/v11.9.0/bin/node)
npm : 7.9.0
OS : macOS Big Sur

And the package.json is the following:

{
“name”: “app”,
“version”: “0.2”,
“author”: “”,
“homepage”: “”,
“private”: true,
“scripts”: {
“start”: “ionic-app-scripts serve”,
“clean”: “ionic-app-scripts clean”,
“build”: “ionic-app-scripts build”,
“lint”: “ionic-app-scripts lint”
},
“dependencies”: {
@angular/animations”: “5.2.11”,
@angular/common”: “5.2.11”,
@angular/compiler”: “5.2.11”,
@angular/compiler-cli”: “5.2.11”,
@angular/core”: “5.2.11”,
@angular/forms”: “5.2.11”,
@angular/http”: “5.2.11”,
@angular/platform-browser”: “5.2.11”,
@angular/platform-browser-dynamic”: “5.2.11”,
@ionic-native/ble”: “^4.19.0”,
@ionic-native/core”: “^4.11.0”,
@ionic-native/email-composer”: “^4.20.0”,
@ionic-native/file”: “^4.20.0”,
@ionic-native/file-transfer”: “^5.14.0”,
@ionic-native/ftp”: “^4.20.0”,
@ionic-native/http”: “^4.20.0”,
@ionic-native/keyboard”: “^5.10.0”,
@ionic-native/native-audio”: “^4.20.0”,
@ionic-native/network”: “^4.20.0”,
@ionic-native/network-interface”: “^4.20.0”,
@ionic-native/printer”: “^4.20.0”,
@ionic-native/splash-screen”: “~4.17.0”,
@ionic-native/sqlite”: “^4.19.0”,
@ionic-native/status-bar”: “^4.20.0”,
@ionic/app-scripts”: “3.2.3”,
@ionic/pro”: “2.0.4”,
@ionic/storage”: “^2.2.0”,
“angular2-uuid”: “^1.1.1”,
“cordova”: “^10.0.0”,
“cordova-android-support-gradle-release”: “^3.0.1”,
“cordova-browser”: “5.0.4”,
“cordova-pdf-generator”: “^2.0.8”,
“cordova-plugin-advanced-http”: “^2.3.1”,
“cordova-plugin-ble-central”: “~1.2.2”,
“cordova-plugin-compat”: “^1.2.0”,
“cordova-plugin-device”: “^2.0.2”,
“cordova-plugin-email-composer”: “^0.9.2”,
“cordova-plugin-file”: “~6.0.1”,
“cordova-plugin-file-transfer”: “^1.7.1”,
“cordova-plugin-ftp”: “^1.1.1”,
“cordova-plugin-ionic-keyboard”: “^2.1.3”,
“cordova-plugin-ionic-webview”: “^2.3.1”,
“cordova-plugin-nativeaudio”: “^3.0.9”,
“cordova-plugin-network-information”: “^2.0.2”,
“cordova-plugin-networkinterface”: “^2.0.0”,
“cordova-plugin-printer”: “git+https://github.com/katzer/cordova-plugin-printer.git”,
“cordova-plugin-shell-exec”: “^1.0.0”,
“cordova-plugin-splashscreen”: “^5.0.3”,
“cordova-plugin-statusbar”: “^2.4.3”,
“cordova-plugin-whitelist”: “^1.3.4”,
“cordova-res”: “^0.6.0”,
“cordova-sqlite-storage”: “^3.4.0”,
“global”: “^4.4.0”,
“ionic-angular”: “3.9.2”,
“ionicons”: “3.0.0”,
“mobx”: “^5.14.0”,
“mobx-angular”: “^3.0.1”,
“rxjs”: “5.5.11”,
“sw-toolbox”: “3.6.0”,
“zone.js”: “0.8.26”
},
“devDependencies”: {
“cordova-android”: “^9.1.0”,
“galletas-plugin-sql-server”: “file:…/galletas-plugin-sql-server”,
“send-mail-cordova-plugin”: “file:…/com.autentia.plugin.sendmail”,
“typescript”: “~2.6.2”
},
“description”: “App Quely comerciales autoventa.”,
“cordova”: {
“plugins”: {
“cordova-plugin-whitelist”: {},
“cordova-plugin-statusbar”: {},
“cordova-plugin-device”: {},
“cordova-plugin-splashscreen”: {},
“cordova-plugin-ionic-webview”: {},
“cordova-plugin-ionic-keyboard”: {},
“cordova-plugin-ble-central”: {},
“cordova-plugin-file”: {},
“cordova-plugin-advanced-http”: {},
“cordova-plugin-printer”: {
“ANDROID_SUPPORT_V4_VERSION”: “28.+”
},
“cordova-android-support-gradle-release”: {
“ANDROID_SUPPORT_VERSION”: “27.+”
},
“cordova-sqlite-storage”: {},
“cordova-plugin-nativeaudio”: {},
“cordova-plugin-email-composer”: {},
“cordova-plugin-ftp”: {},
“cordova-plugin-file-transfer”: {},
“cordova-pdf-generator”: {},
“cordova-plugin-network-information”: {},
“cordova-plugin-networkinterface”: {},
“org.apache.cordova.shell-exec”: {},
“com.autentia.plugin.sendmail”: {},
“galletas-plugin-sql-server”: {}
},
“platforms”: [
“browser”,
“android”
]
}
}

I’ve tried to update “@ionic-native/core”: “^4.11.0” but after that, when i run npm install, other packages fails… so I’m a bit lost with npm, dependencies etc…

samy@MacBook-Pro-de-Samuel QLY_App_2019 % npm install
(node:90343) ExperimentalWarning: The fs.promises API is experimental
npm ERR! code ERESOLVE
npm ERR! ERESOLVE unable to resolve dependency tree
npm ERR!
npm ERR! While resolving: app@0.2
npm ERR! Found: @ionic-native/core@4.20.0
npm ERR! node_modules/@ionic-native/core
npm ERR! @ionic-native/core@"^4.11.0" from the root project
npm ERR!
npm ERR! Could not resolve dependency:
npm ERR! peer @ionic-native/core@"^5.1.0" from @ionic-native/file-transfer@5.33.1
npm ERR! node_modules/@ionic-native/file-transfer
npm ERR! @ionic-native/file-transfer@"^5.14.0" from the root project
npm ERR!
npm ERR! Fix the upstream dependency conflict, or retry
npm ERR! this command with --force, or --legacy-peer-deps
npm ERR! to accept an incorrect (and potentially broken) dependency resolution.
npm ERR!
npm ERR! See /Users/samy/.npm/eresolve-report.txt for a full report.

npm ERR! A complete log of this run can be found in:
npm ERR! /Users/samy/.npm/_logs/2021-06-14T16_46_27_670Z-debug.log

I’m a bit desperate because it’s for my company so… please… I pray for your help.

Thanks a lot, Sam