Plugin Installation Fail


#1

Hello,

I’ve spent the weekend geeking out on ionic. It looks great! : ) Unfortunatly, installing my first plugin prevents the ionic build command from running.

some details:

OSX 10.9

myApp git:master ❯ cordova -v                                                                                              ⏎
3.5.0-0.2.6

    myApp git:master ❯ ionic -v
    Ionic CLI version 1.1.0

the plugin installation commands:

myApp git:master ❯ cordova plugin add https://github.com/EddyVerbruggen/SocialSharing-PhoneGap-Plugin.git

myApp git:master ❯ cordova prepare                                                                       

the error (ill spare the details unless they are needed? there are a lot)

clang: error: no such file or directory: '/Users/willbarker/ionictest/myApp/platforms/ios/myApp/Plugins/nl.x-services.plugins.socialsharing/SocialSharing.m'

There isn’t a folder for the plugin at all in:

/Users/willbarker/ionictest/myApp/platforms/ios/myApp/Plugins/

…however the plugin is listed as installed:

Plugins git:master ❯ cordova plugin ls
com.ionic.keyboard 1.0.2 "Keyboard"
nl.x-services.plugins.socialsharing 4.3.2 "SocialSharing"
org.apache.cordova.console 0.2.9 "Console"
org.apache.cordova.device 0.2.10 "Device"

What might i have done wrong?

Thanks for an awesome framework & any help

W


#2

running through the instructions here:

https://cordova.apache.org/docs/en/3.0.0/guide_cli_index.md.html

I built a non-ionic HelloWorld app and added the plugins. the build succeeded.

I then tried a new Ionic project with the name HelloWorld rather than myApp & added a plugin. That built too. the only things i can think is either the myApp name is reserved, the lowercase of myApp is causing problems or something else i did in the app has somehow broken it. Ill start again, making sure the app builds with plugins before writing any code.

W


#3

Is ‘myApp’ your project root for ionic (e.g. is that where your www folder sits?) I’m only building for android, since I’m on a windows machine, but I don’t think (?) there should be a plugin folder within your platform directory–on Android, they sit on the same level at your project root. Perhaps you added the plugin within the ios project folder? Would suggest removing the plugin, then trying to add it again from your project root.

I’m having problems with this plugin too --basically ‘cordova prepare android’ isn’t doing anything, my index isn’t getting the script tag, and it’s not moving my JS - don’t want that to create build issues with iOS later when I have a macbook, or Ionic Builder is out.


#4

is ‘myApp’ your project root for ionic

yep. But i added the plugin from the myApp root. I had trouble with all the plugins i tried to install. I think it was more to do with the way i set up the ionic project than the actual plugins.

Ill update here if i come across any related issues as i copy paste the code i had written into the new project.

W