Please update @angular/cli. Angular 5+ requires at least Angular CLI 1.5+


#1

After update Ionic to Ionic 3.9.2 I receive the error when building with --prod flag (ionic). Could anyone suggest please, how to fix this ?

@ionic/cli-utils  : 1.18.0
ionic (Ionic CLI) : 3.18.0
global packages:

cordova (Cordova CLI) : 7.1.0
local packages:

@ionic/app-scripts : 2.0.2
Cordova Platforms  : android 6.2.3
Ionic Framework    : ionic-angular 3.9.2
System:

Android SDK Tools : 25.2.5
Node              : v6.9.0
npm               : 3.10.8
OS                : Windows 7
Environment Variables:

ANDROID_HOME : C:\Users\anton\AppData\Local\Android\sdk
Misc:

backend : pro


#2

have you updated app script to 3.1.0


#3

vks_gautam1, yes … i run npm install @ionic/app-scripts@latest --save-dev and solve problem. But now have another problem with rxjs.


#4

you can open new issue as new post for it . as will help others to search same kind of problem in future…