Phython error when trying to start new Ionic project


#1

I have recently updated the Ionic CLI, and now when I try to start a new project I get the following error…

	D:\dev>ionic start viewportTest

	? What starter would you like to use: blank
	√ Creating directory .\viewportTest - done!
	√ Downloading and extracting blank starter - done!

	? Would you like to integrate your new app with Cordova to target native iOS and Android? Yes
	√ Personalizing ionic.config.json and package.json - done!
	> ionic integrations enable cordova --quiet
	√ Downloading integration cordova - done!
	√ Copying integrations files to project - done!
	[OK] Added cordova integration!

	Installing dependencies may take several minutes.

	  *   IONIC  DEVAPP  *

	 Speed up development with the Ionic DevApp, our fast, on-device testing mobile app

	  -     Test on iOS and Android without Native SDKs
	  -     LiveReload for instant style and JS updates

	 ️-->    Install DevApp: https://bit.ly/ionic-dev-app    <--

	> npm i
	× Running command - failed!
	[ERROR] An error occurred while running npm i (exit code 1):



			> node-sass@4.9.0 install D:\dev\viewportTest\node_modules\node-sass
			> node scripts/install.js

			Downloading binary from https://github.com/sass/node-sass/releases/download/v4.9.0/win32-x64-57_binding.node
			Cannot download "https://github.com/sass/node-sass/releases/download/v4.9.0/win32-x64-57_binding.node":

			ESOCKETTIMEDOUT

			Hint: If github.com is not accessible in your location
				   try setting a proxy via HTTP_PROXY, e.g.

				   export HTTP_PROXY=http://example.com:1234

			or configure npm proxy via

				   npm config set proxy http://example.com:8080

			> uglifyjs-webpack-plugin@0.4.6 postinstall D:\dev\viewportTest\node_modules\uglifyjs-webpack-plugin
			> node lib/post_install.js


			> node-sass@4.9.0 postinstall D:\dev\viewportTest\node_modules\node-sass
			> node scripts/build.js

			Building: C:\Program Files\nodejs\node.exe D:\dev\viewportTest\node_modules\node-gyp\bin\node-gyp.js rebuild
			--verbose --libsass_ext= --libsass_cflags= --libsass_ldflags= --libsass_library=
			gyp info it worked if it ends with ok
			gyp verb cli [ 'C:\\Program Files\\nodejs\\node.exe',
			gyp verb cli   'D:\\dev\\viewportTest\\node_modules\\node-gyp\\bin\\node-gyp.js',
			gyp verb cli   'rebuild',
			gyp verb cli   '--verbose',
			gyp verb cli   '--libsass_ext=',
			gyp verb cli   '--libsass_cflags=',
			gyp verb cli   '--libsass_ldflags=',
			gyp verb cli   '--libsass_library=' ]
			gyp info using node-gyp@3.7.0
			gyp info using node@8.11.3 | win32 | x64
			gyp verb command rebuild []
			gyp verb command clean []
			gyp verb clean removing "build" directory
			gyp verb command configure []
			gyp verb check python checking for Python executable "C:\Program Files\Python36\python.exe" in the PATH
			gyp verb `which` succeeded C:\Program Files\Python36\python.exe C:\Program Files\Python36\python.exe
			gyp verb check python version `C:\Program Files\Python36\python.exe -c "import platform;
			print(platform.python_version());"` returned: "3.6.2\r\n"
			gyp verb could not find "C:\Program Files\Python36\python.exe". checking python launcher
			gyp verb could not find "C:\Program Files\Python36\python.exe". guessing location
			gyp verb ensuring that file exists: C:\Python27\python.exe
			gyp ERR! configure error
			gyp ERR! stack Error: Can't find Python executable "C:\Program Files\Python36\python.exe", you can set the
			PYTHON env variable.
			gyp ERR! stack     at PythonFinder.failNoPython
			(D:\dev\viewportTest\node_modules\node-gyp\lib\configure.js:492:19)
			gyp ERR! stack     at PythonFinder.<anonymous>
			(D:\dev\viewportTest\node_modules\node-gyp\lib\configure.js:517:16)
			gyp ERR! stack     at D:\dev\viewportTest\node_modules\graceful-fs\polyfills.js:284:29
			gyp ERR! stack     at FSReqWrap.oncomplete (fs.js:152:21)
			gyp ERR! System Windows_NT 10.0.17134
			gyp ERR! command "C:\\Program Files\\nodejs\\node.exe"
			"D:\\dev\\viewportTest\\node_modules\\node-gyp\\bin\\node-gyp.js" "rebuild" "--verbose" "--libsass_ext="
			"--libsass_cflags=" "--libsass_ldflags=" "--libsass_library="
			gyp ERR! cwd D:\dev\viewportTest\node_modules\node-sass
			gyp ERR! node -v v8.11.3
			gyp ERR! node-gyp -v v3.7.0
			gyp ERR! not ok
			Build failed with error code: 1
			npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.4 (node_modules\fsevents):
			npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.4: wanted
			{"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"})

			npm ERR! code ELIFECYCLE
			npm ERR! errno 1
			npm ERR! node-sass@4.9.0 postinstall: `node scripts/build.js`
			npm ERR! Exit status 1
			npm ERR!
			npm ERR! Failed at the node-sass@4.9.0 postinstall script.
			npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

			npm ERR! A complete log of this run can be found in:
			npm ERR!     C:\Users\pchapman\AppData\Roaming\npm-cache\_logs\2018-07-04T04_54_33_321Z-debug.log



	D:\dev>

This is on a WIndows 10 machines, and I have set the PYTHON env variable, which it is actually finding (ie my Python IS at C:\Program Files\Python36\python.exe"

python

Anyone have any ideas?

Thanks in advance


#2

Hello,

maybe the connection got no response in time. Maybe you should try it later again or look what is slowing down your connection.

Best regards, anna-liebt


#3

What do you know, I tried it again (after a break), and it now works! Never thought it was anything to do with connectivity.

Thanks heaps for that!