Permission Error With Sass Setup

I am a new Ionic developer and have created a new project on Mac 10.9.5. I have added no code, markup, or css of my own. Then I ran

ionic setup sass

Whenever I try to serve files to the browser, I get this error:

Error: EACCES, permission denied '/Users/Me/.config/configstore/bower-github.yml'
You don't have access to this file.

    at Object.fs.openSync (evalmachine.<anonymous>:427:18)
    at Object.fs.readFileSync (evalmachine.<anonymous>:284:15)
    at Object.create.all.get (/Users/Me/myfolder/applications/myapp/node_modules/bower/node_modules/configstore/index.js:34:29)
    at Object.Configstore (/Users/Me/myfolder/applications/myapp/node_modules/bower/node_modules/configstore/index.js:27:44)
    at readCachedConfig (/Users/Me/myfolder/applications/myapp/node_modules/bower/lib/config.js:22:23)
    at defaultConfig (/Users/Me/myfolder/applications/myapp/node_modules/bower/lib/config.js:11:24)
    at Object.<anonymous> (/Users/Me/myfolder/applications/myapp/node_modules/bower/lib/index.js:40:32)
    at Module._compile (module.js:456:26)
    at Object.Module._extensions..js (module.js:474:10)
    at Module.load (module.js:356:32)

I have tried a lot of combinations of chown’s and sudo’s. The only thing that seems to work is sudo ionic serve.

I find it strange that this error happens without me doing anything, and I worry that this (or something related) could come back to bite me down the road. I haven’t noticed this problem or the sudo solution in any documentation. Am I doing something dumb?

Any advice is appreciated.

Thanks.

I got a similar error when trying to install the tinder cards example. I ended up running bower with the sudo command and the --allow-root option, so:

sudo bower install ionic-contrib-tinder-cards --allow-root

then it worked properly, an annoying error which I’m still not 100% clear on.

Anyway I’m not sure if that helps, best of luck further.