$ npm install ionic -g

$ npm install ionic -g
(node:2112) fs: re-evaluating native module sources is not supported. If you are using the graceful-fs module, please update it to a more recent version.
info trying registry request attempt 1 at 14:58:38
http GET https://registry.npmjs.org/ionic
http 200 https://registry.npmjs.org/ionic
info trying registry request attempt 1 at 15:01:26
http GET https://registry.npmjs.org/ionic/app-generators
http 404 https://registry.npmjs.org/ionic/app-generators
npm ERR! 404 Not Found
npm ERR! 404
npm ERR! 404 ‘ionic/app-generators’ is not in the npm registry.
npm ERR! 404 You should bug the author to publish it
npm ERR! 404 It was specified as a dependency of 'ionic’
npm ERR! 404
npm ERR! 404 Note that you can also install from a
npm ERR! 404 tarball, folder, or http url, or git url.

npm ERR! System Windows_NT 10.0.14393
npm ERR! command “C:\Program Files\nodejs\node.exe” “C:\Program Files\nodejs\node_modules\npm\bin\npm-cli.js” “install” “ionic” "-g"
npm ERR! cwd C:\Users\vinicius_clarindo\Documents
npm ERR! node -v v6.9.5
npm ERR! npm -v 1.4.28
npm ERR! code E404
npm ERR! not ok code 0

Can you provide your node version and npm verison?

node -v 

npm -v

C:\Users\vinicius_clarindo>node -v

C:\Users\vinicius_clarindo>npm -v

Are you running this from an admin command prompt?

yes, i’m running this from an admin.

Hmm, alright, could you try

npm uninstall -g ionic
npm cache clean
npm install -g ionic

Hi, i think it is still not working because the npm registry for @ionic/app-generators is returning empty data

no, that does exist.

@ViniciusClarindo are you using any custom npm settings?
Like a custom registry at all?

Yes, my bad

i finally fixed it by removing chocolatey installed on my computer, and then reinstall node, and install nvm to change the node version and i think it should work