Npm install -g ionic fails

Hey community! Whenever I try to install Ionic I get the following Errors. I’m trying to install ionic now for about 2 month. Has someone any idea what the problem may be?

Ps. I also can’t use the comand “ionic” in my console after the installation.
Thank you in advance

Can you include the log file? it should be easier to read for everyone.

For some reason there was no log file created. But this one is from another project.

ENOENT generally means that a file or folder is not available.
Please try this and tell me if it works

Update your node and npm to the latest version. Current stable for node is 6.10.0. Your npm 3.10.10 seems to be a bit older. See here:

The latest verified release is 4.3.
Run the command “npm install npm@latest -g”

My node version should be the latest. I installed it this month. I tryed the command “npm install npm@latest -g”. After this I tryed to install ionic but it failed again. Here is the new log file.

I have exactly this same problem when installing the latest Ionic 2 CLI - an error message containing “ENOENT … ansi”:

ENOENT: no such file or directory … ansi-e14136a8

I’m running node 6.9.1 and npm 3.10.8 (these are stable ‘LTS’ versions although not the very latest).

I also see a Github issue about this problem, and it also includes a solution:

Haven’t tried it but the solution is supposed to be to do a “npm -g remove ionic” first before installing the new version.

1 Like

Thanks a lot! It worked :smiley: