Npm install error "npm sass"


#1

I update my node version.
i clone ionic-conference projet from https://github.com/driftyco/ionic-conference-app when i do npm install i get this error

C:\mylab\Ionic\testf\ionic-conference-app>npm install
npm WARN deprecated cross-spawn-async@2.2.4: cross-spawn no longer requires a build toolchain, use it instead!
npm WARN prefer global node-gyp@3.3.1 should be installed with -g
> node-sass@3.7.0 install C:\mylab\Ionic\testf\ionic-conference-app\node_modules\node-sass
> node scripts/install.js
Cannot download "'https://github.com/sass/node-sass/releases/download'/v3.7.0/win32-x64-47_binding.node":
Invalid URI "%27https://github.com/sass/node-sass/releases/download%27/v3.7.0/win32-x64-47_binding.node"
Hint: If github.com is not accessible in your location
      try setting a proxy via HTTP_PROXY, e.g.
      export HTTP_PROXY=http://example.com:1234
or configure npm proxy via
      npm config set proxy http://example.com:8080
> node-sass@3.7.0 postinstall C:\mylab\Ionic\testf\ionic-conference-app\node_modules\node-sass
> node scripts/build.js
Building: C:\Program Files\nodejs\node.exe C:\mylab\Ionic\testf\ionic-conference-app\node_modules\node-gyp\bin\node-gyp.js rebuild --verbose --libsass_ext= --libs
ass_cflags= --libsass_ldflags= --libsass_library=
gyp info it worked if it ends with ok
gyp verb cli [ 'C:\\Program Files\\nodejs\\node.exe',
gyp verb cli   'C:\\mylab\\Ionic\\testf\\ionic-conference-app\\node_modules\\node-gyp\\bin\\node-gyp.js',
gyp verb cli   'rebuild',
gyp verb cli   '--verbose',
gyp verb cli   '--libsass_ext=',
gyp verb cli   '--libsass_cflags=',
gyp verb cli   '--libsass_ldflags=',
gyp verb cli   '--libsass_library=' ]
gyp info using node-gyp@3.3.1
gyp info using node@5.11.0 | win32 | x64
gyp verb command rebuild []
gyp verb command clean []
gyp verb clean removing "build" directory
gyp verb command configure []
gyp verb check python checking for Python executable "C:\Utilisateurs\A627290\AppData\Local\Programs\Python\Python36" in the PATH
gyp verb `which` failed Error: not found: C:\Utilisateurs\A627290\AppData\Local\Programs\Python\Python36
gyp verb `which` failed     at getNotFoundError (C:\mylab\Ionic\testf\ionic-conference-app\node_modules\which\which.js:14:12)
gyp verb `which` failed     at F (C:\mylab\Ionic\testf\ionic-conference-app\node_modules\which\which.js:69:19)
gyp verb `which` failed     at E (C:\mylab\Ionic\testf\ionic-conference-app\node_modules\which\which.js:81:29)
gyp verb `which` failed     at C:\mylab\Ionic\testf\ionic-conference-app\node_modules\which\which.js:90:16
gyp verb `which` failed     at C:\mylab\Ionic\testf\ionic-conference-app\node_modules\isexe\index.js:44:5
gyp verb `which` failed     at C:\mylab\Ionic\testf\ionic-conference-app\node_modules\isexe\windows.js:29:5
gyp verb `which` failed     at FSReqWrap.oncomplete (fs.js:82:15)
gyp verb `which` failed  C:\Utilisateurs\A627290\AppData\Local\Programs\Python\Python36 { [Error: not found: C:\Utilisateurs\A627290\AppData\Local\Programs\Python
\Python36] code: 'ENOENT' }
gyp verb could not find "C:\Utilisateurs\A627290\AppData\Local\Programs\Python\Python36". guessing location
gyp verb ensuring that file exists: C:\Python27\python.exe
gyp ERR! configure error
gyp ERR! stack Error: Can't find Python executable "C:\Utilisateurs\A627290\AppData\Local\Programs\Python\Python36", you can set the PYTHON env variable.
gyp ERR! stack     at failNoPython (C:\mylab\Ionic\testf\ionic-conference-app\node_modules\node-gyp\lib\configure.js:401:14)
gyp ERR! stack     at C:\mylab\Ionic\testf\ionic-conference-app\node_modules\node-gyp\lib\configure.js:356:11
gyp ERR! stack     at FSReqWrap.oncomplete (fs.js:82:15)
gyp ERR! System Windows_NT 6.1.7601
gyp ERR! command "C:\\Program Files\\nodejs\\node.exe" "C:\\mylab\\Ionic\\testf\\ionic-conference-app\\node_modules\\node-gyp\\bin\\node-gyp.js" "rebuild" "--verb
ose" "--libsass_ext=" "--libsass_cflags=" "--libsass_ldflags=" "--libsass_library="
gyp ERR! cwd C:\mylab\Ionic\testf\ionic-conference-app\node_modules\node-sass
gyp ERR! node -v v5.11.0
gyp ERR! node-gyp -v v3.3.1
gyp ERR! not ok
Build failed
npm WARN optional Skipping failed optional dependency /chokidar/fsevents:
npm WARN notsup Not compatible with your operating system or architecture: fsevents@1.0.12
npm WARN angular2@2.0.0-beta.16 requires a peer of reflect-metadata@0.1.2 but none was installed.
npm WARN angular2@2.0.0-beta.16 requires a peer of zone.js@^0.6.12 but none was installed.
npm ERR! Windows_NT 6.1.7601
npm ERR! argv "C:\\Program Files\\nodejs\\node.exe" "C:\\Utilisateurs\\A627290\\AppData\\Roaming\\npm\\node_modules\\npm\\bin\\npm-cli.js" "install"
npm ERR! node v5.11.0
npm ERR! npm  v3.8.9
npm ERR! code ELIFECYCLE
npm ERR! node-sass@3.7.0 postinstall: `node scripts/build.js`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the node-sass@3.7.0 postinstall script 'node scripts/build.js'.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the node-sass package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR!     node scripts/build.js
npm ERR! You can get information on how to open an issue for this project with:
npm ERR!     npm bugs node-sass
npm ERR! Or if that isn't available, you can get their info via:
npm ERR!     npm owner ls node-sass
npm ERR! There is likely additional logging output above.
npm ERR! Please include the following file with any support request:
npm ERR!     C:\mylab\Ionic\testf\ionic-conference-app\npm-debug.log

#2

Got the same error with “node-sass”. But I can resolved it by roll back to Node 4.4 (Recommended).