Npm and updating ionic, angular, angular material?

I was trying to install a new module, but npm thinks things are not compatible, but I don’t even see where it even refers to the package I’m trying to install. Yes, I’m a beginner at NPM.

Do I use some nice ionic command, an angular(ng) command, or just some npm commands?
Is there any documentation on the subject?

I tried doing some npm updates before and got the whole project messed up. I’m pretty much a beginner on all these frameworks and simply want to bring things update enough to continue to develop, (latest production release would be good).

Yes, I need some handholding. What is the correct process?

PS C:\code\myco-match> npm i @ngbmodule/material-carousel
npm i @ngbmodule/material-carousel
npm ERR! code ERESOLVE
npm ERR! ERESOLVE unable to resolve dependency tree
npm ERR!
npm ERR! While resolving: myco-match@0.0.1
npm ERR! Found: @angular/core@13.2.7
npm ERR! node_modules/@angular/core
npm ERR! @angular/core@"~13.2.3" from the root project
npm ERR!
npm ERR! Fix the upstream dependency conflict, or retry
npm ERR! this command with --force, or --legacy-peer-deps
npm ERR! to accept an incorrect (and potentially broken) dependency resolution.
npm ERR!
npm ERR! See C:\Users\pareh\AppData\Local\npm-cache\eresolve-report.txt for a full report.

npm ERR! A complete log of this run can be found in:
npm ERR! C:\Users\pareh\AppData\Local\npm-cache_logs\2022-04-06T23_50_45_727Z-debug-0.log
PS C:\code\myco-match> ionic -v
6.19.0
Your global Angular CLI version (13.3.1) is greater than your local version (13.2.6). The local Angular CLI version is used.

To disable this warning use “ng config -g cli.warnings.versionMismatch false”.

Angular CLI: 13.2.6
Node: 16.14.2
Package Manager: npm 8.5.0
OS: win32 x64

Angular: 13.2.7

use npm i --legacy-peer-deps or npm i --force

Thank you for your reply.
I ended up using the process at