Node 8 and npm 5 are out - Your experience with Ionic?

https://nodejs.org/en/blog/release/v8.0.0/
http://blog.npmjs.org/post/161081169345/v500

Anyone tested Ionic CLI and Cordova on this yet?

3 Likes
PS C:\Users\Jan\Documents> npm install -g cordova ionic
npm WARN deprecated node-uuid@1.4.8: Use uuid module instead
C:\Program Files\nodejs\ionic -> C:\Program Files\nodejs\node_modules\ionic\bin\ionic
C:\Program Files\nodejs\cordova -> C:\Program Files\nodejs\node_modules\cordova\bin\cordova
added 729 packages in 130.33s

ionic start fails because I am on Windows and there seem to be some thing wrong with node-sass for now. I think it comes from app-scripts, so I created an issue there: https://github.com/ionic-team/ionic-app-scripts/issues/1016

cordova 7 was giving gradle problem . npm 5 was giving error when i try to install npm package in project.

If you upgrade to Node 8 on macOS and have an existing project, you will get the following error:

Error: Missing binding .../node_modules/node-sass/vendor/darwin-x64-48/binding.node
Node Sass could not find a binding for your current environment: OS X 64-bit with Node.js 6.x

Found bindings for the following environments:
  - OS X 64-bit with Unsupported runtime (51)

You need to run the following:

npm rebuild node-sass
6 Likes

After running npm rebuild node-sass as mentioned by @Perrenoud, everything seems to be working fine.

1 Like

My PR should fix this: https://github.com/ionic-team/ionic-app-scripts/pull/1012

1 Like

When looking to update an existing ionic app I followed the initial steps here:

But I’m getting 404 not found error during app creation:

> npm install
✖ Running command - failed!
[ERROR] An error occurred while running npm install (exit code 1):

        npm WARN deprecated object-keys@0.2.0: Please update to the latest object-keys
        npm WARN prefer global node-gyp@3.6.1 should be installed with -g

        > node-sass@4.5.0 install C:\Users\joe.user\Documents\newapp\node_modules\node-sass
        > node scripts/install.js

        Downloading binary from https://github.com/sass/node-sass/releases/download/v4.5.0/win32-x64-57_binding.node
        Cannot download "https://github.com/sass/node-sass/releases/download/v4.5.0/win32-x64-57_binding.node":

        HTTP error 404 Not Found

using windows with latest nodejs and ionic.

Any way around this as of now?

See Node 8 and npm 5 are out - Your experience with Ionic? and the issue I linked there.

any work around of this…
look like nothing in hand right now .

The issue you are linking to is different, and concerns a bug in npm that saves a Github URL instead of a version number in package.json. Did you encounter this with Ionic and npm5? Shouldn’t happen as the version number of node-sass comes from @ionic/app-scripts and is hardcoded there. (See the issue I linked in post #2)

A post was split to a new topic: Error: EPERM: operation not permitted

I got node-sass error, couldn’t find it and neither rebuild it to my environment (Windows 64). It tries to download but can’t find it, then it asks to update my plugins but it’s all up to date.
Rolled back to Nodejs 6.10.

this worked for me

As a workaround, manually change entry in package-lock.json or npm-shrinkwrap.json

from:

    "node-sass": {
      "version": "http://npmcache.softax.local/node-sass/-/node-sass-4.5.3.tgz",
      "integrity": "sha1-0JydEXlkEjnRuX/8YjH9zsU+FWg="
    },
to:

    "node-sass": {
      "version": "4.5.3",
      "resolved": "http://npmcache.softax.local/node-sass/-/node-sass-4.5.3.tgz",
      "integrity": "sha1-0JydEXlkEjnRuX/8YjH9zsU+FWg="
    },
2 Likes

This workaround worked for me. Thanks!

@ionic/app-scripts finally released 1.3.8 with the node sass fixes!


So we should be fine on Windows now too to use node8 and npm5.

1 Like

I missed your post, your tests were successful with Node 8 after the publication of ionic-app-scripts 1.3.8?

P.S.: Just read that article, the performance of Node 8 looks promising https://hackernoon.com/upgrading-from-node-6-to-node-8-a-real-world-performance-comparison-3dfe1fbc92a3

Yep, stuff is working now just fine.

1 Like

Just fyi, even with 1.3.8, I had to create a blank file named src/service-worker.js in order to stop a build error from happening. I don’t think this is an issue if you’re creating a new project with 1.3.8.

Uh interesting. Did you create an issue for that? I always though service worker was optional and not a required thing.

It was a suggestion by user paulonbastos in this GitHub issue (which I did create, but I can’t take any credit for the solution.)