No target specified, defaulting to emulator


#1

I have started following a pluralsight ionic course by Steve Michelotti, but have a problem deploying my app to my android phone.

Here are the details:-

  1. ionic run android displays ‘No target specified, defaulting to emulator’.

  2. I have my Acer Liquid Jade Z phone connect to my windows 8 usb.

  3. Phone displays ‘Connected as a media device (MTP)’

  4. I have enabled USB Debugging on my phone.

  5. ‘adb devices’ displays empty list of attached devices.

BTW: My app works fine with the emulator.

Any help in getting this working on my android phone appreciated.

Regards, Paul


#2

Have you tried: ionic run android --device ?
I must specify --device for iOS when I want to run on the phone.


#3

Sorry for the delay, Just got back from holiday.
I tried your suggestion, but it didn’t work. I think the problem is driver related, because ‘adb devices’ returns an empty list of attached devices.
My phone appears in windows device manager ‘Other’ as ‘S57’, but shows a ‘no driver installed’ error. I have tried manually updating the driver from AppData>Local>Android>sdk>extras>google>usb_driver, but it does not recognize any driver files.

Any idea what I am doing wrong?

Regards, Paul