NFC plugin error

I have installed NFC plugin but whnen I tried to make build iy giving me this error.
error: diamond
operator is not supported in -source 1.6
private final List intentFilters = new ArrayList<>();
^
(use -source 7 or higher to enable diamond operator)

I searched about this error and says that it needs jAVA 8 or higher version.I have already JAVA 8 .Please do help
Thanks

1 Like

I Wish ionic would reply to this… Same happened to me, so i thought what the hell, let me just add the plugin and see if it at least builds on the pro portal… and it doesn’t… I realy am getting frustrated with this ionic… The are releasing version 4 now but 3 isn’t even working!!!