Network Request Error Only When Running on Actual Phone

I am having a really weird issue where I can make API calls from the PWA and from the iOS simulator.

But when I run the app on my actual iPhone the API call fails with a “Network Error”. But I have no idea what is causing this issue.

Has anyone experienced this? I’ve killed A LOT of time on this and its starting to drive me a bit crazy!

Thank you for any tips or help,


First question is whether you’re using https endpoints everywhere. If not, try that and see if the problem persists.

Yes… I’ve tried to make calls to the production site as well as tunneling to a localhost port using ngrok, both of which are hosted on HTTPS, but still no love.

I have to think it is some simple but esoteric thing but I’m at a lost as to what that could be… using tunneling I literally never see the request get to the server.

Is there some kind of permission on an iPhone app that needs to be set to make API calls in an app?


That makes me suspect CORS. Might that be the issue?

Yes… I think the issue was on the server… I had to update the hosts that could call the API so the tunneling app could make the call.

Thank you for taking the time to respond… it definitely helped!