Native Zip doesn't work

Hi,

I can’t use the native plugin Zip. The plugins is not recognized .
import { Zip } from ‘ionic-native’;
Error : “/node_modules/ionic-native/dist/index has no exported member” ‘Zip’

I have correctly installed the plugin with : ionic plugin add cordova-plugin-zip.
I have been working with many plugins and this is the only one I have issues with.

Do you have a solution ?

IDE : JetBrains WebStorm
Cordova CLI: 6.3.1
Ionic Framework Version: 2.0.0-beta.11
Ionic CLI Version: 2.0.0-beta.37
Ionic App Lib Version: 2.0.0-beta.20
Node Version: v4.4.5

Thank you.

Julien

1 Like

I have the same issue.

It looks like the plugin installation is not working somehow…

Can you tell me if there is a fix coming soon ?

1 Like

Zip was added in the 1.3.20 release.

Please update your ionic-native version in the package.json to be 1.3.20.

1 Like