Metadata version mismatch for module node_modules/ng2-emoji/ng2-emoji.d.ts, found version 3, expected 1 on ionic build android --release --prod


#1

Metadata version mismatch for module
node_modules/ng2-emoji/ng2-emoji.d.ts, found version 3, expected 1

ionic build android --release --prod

error log

[17:18:28]  build prod failed: Metadata version mismatch for module 
        D:/projects/siilo/node_modules/ng2-emoji/ng2-emoji.d.ts, found version 3, expected 1 
[17:18:28]  ionic-app-script task: "build" 
[17:18:28]  Error: Metadata version mismatch for module D:/projects/siilo/node_modules/ng2-emoji/ng2-emoji.d.ts, found 
        version 3, expected 1 
Error: Metadata version mismatch for module D:/projects/siilo/node_modules/ng2-emoji/ng2-emoji.d.ts, found version 3, expected
1
at StaticReflector.getModuleMetadata (D:\projects\siilo\node_modules\@angular\compiler-cli\src\static_reflector.js:500:23)
at D:\projects\siilo\node_modules\@angular\compiler-cli\src\codegen.js:122:46
at Array.forEach (native)
at extractProgramSymbols (D:\projects\siilo\node_modules\@angular\compiler-cli\src\codegen.js:120:10)
at CodeGenerator.codegen (D:\projects\siilo\node_modules\@angular\compiler-cli\src\codegen.js:57:29)
at D:\projects\siilo\node_modules\@ionic\app-scripts\dist\aot\aot-compiler.js:51:34
npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! ionic-hello-world@ ionic:build: `ionic-app-scripts build "--release" "--prod"`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the ionic-hello-world@ ionic:build script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR!     C:\Users\Ikrok-PC\AppData\Roaming\npm-cache\_logs\2017-06-01T14_18_28_386Z-debug.log

ionic info:

cordova CLI: 7.0.1
Ionic Framework Version: 2.0.0
Ionic CLI Version: 2.2.3
Ionic App Lib Version: 2.2.1
Ionic App Scripts Version: 1.0.0
ios-deploy version: Not installed
ios-sim version: Not installed
OS: Windows 10
Node Version: v6.10.0
Xcode version: Not installed

Help.


#2

Did you follow the entire conversation in the bug you found? Specifically the bit about forRoot()?