Mac OS El Capitan Unable to determine Android SDK directory error


#1

Hi,

I bought new mac book pro,it has El Capitan OS. I install nodejs,npm,cordova,ionic, java jdk and android sdk 24.

Outputs of commands :

java -version
java version "1.8.0_102"
Java™ SE Runtime Environment (build 1.8.0_102-b14)
Java HotSpot™ 64-Bit Server VM (build 25.102-b14, mixed mode)

cordova -version
6.2.0

ionic -version
1.7.16

echo $PATH
/usr/local/bin
:/usr/bin
:/bin
:/usr/sbin
:/sbin
:/Users/fatihayyildiz/Library/Android/sdk/tools
:/Users/fatihayyildiz/Library/Android/sdk/platform-tools
:/Users/fatihayyildiz/Library/Android/sdk
:/Library/Frameworks/Mono.framework/Versions/Current/Commands
:/Users/fatihayyildiz/Library/Android/sdk/platform-tools
:/Users/fatihayyildiz/Library/Android/sdk/tools
:/Users/fatihayyildiz/Library/Android/sdk/platform-tools
:/Users/fatihayyildiz/Library/Android/sdk/tools

echo $ANDROID_HOME
/Users/fatihayyildiz/Library/Android/sdk

echo $JAVA_HOME
/Library/Java/Home

So when I run cordova build android on my project root directory I am getting this error

  • What went wrong:
    Execution failed for task ‘:processDebugResources’.

com.android.ide.common.process.ProcessException: org.gradle.process.internal.ExecException: Process ‘command ‘/Users/fatihayyildiz/Library/Android/sdk/build-tools/24.0.1/aapt’’ finished with non-zero exit value 1

When I am going to /platforms/android and run sudo ./gradlew assembleDebug --info I am getting this error

  • What went wrong:
    A problem occurred evaluating root project ‘android’.

Unable to determine Android SDK directory.

But when I run “android” command in terminal ,its open Android SDK Manager and SDK’s are already installed.

This screenshot from Android Studio SDK Tools

So anybody get this issue before ?


#2

Me now? How did you fix that?


#3

First step:
Run ionic cordova requirements.
(And post you ionic info output)