Keyboard doesn't show when building with --prod on Android Nougat


#1

I am encountering a weird issue with the keyboard only if I run it using --prod. When the input field is empty, I can tap on it, the keyboard shows and I can start typing. I go to the next field and it works.

However, as soon as I leave the field or if the field is not empty, when I try to make a change by tapping the input field again, the keyboard doesn’t show up. It seems as if it is locked.

It happens for all input types (text, email etc). And only happens if I run with --prod on Android 7 Nougat. If I just do a ionic cordova run android, it works ok.

I tested with Android 5.1 and it seems to work fine. Anyone with the same issue? Or does Ionic not support Android 7?

Here is my ionic info output:

cli packages: (/usr/local/lib/node_modules)

    @ionic/cli-utils  : 1.18.0
    ionic (Ionic CLI) : 3.18.0

global packages:

    cordova (Cordova CLI) : 7.0.1 

local packages:

    @ionic/app-scripts : 2.1.4
    Cordova Platforms  : android 6.2.3
    Ionic Framework    : ionic-angular 3.6.1

System:

    Android SDK Tools : 25.2.5
    ios-deploy        : 1.9.1 
    ios-sim           : 3.1.1 
    Node              : v6.10.0
    npm               : 4.2.0 
    OS                : macOS Sierra
    Xcode             : Xcode 9.0.1 Build version 9A1004

#2

I have tried building with --aot and it works. Looks like the issue is only with --prod flag. I can’t seem to find any fix on this issue.

Currenty, I am implementing a workaround by calling setFocus() when the input is tapped.


#3

I’m suddenly running into this issue myself.

I updated to ionic-angular 3.9.2 because I couldn’t get the native camera to launch.
Now the camera works but the keyboard doesn’t launch when I tap on text fields.
Like you, I only experience this when I use the prod flag.

I tried uninstalling and reinstalling ionic-plugin-keyboard, but it had no effect.

Were you able to find the cause of this issue or a solution?


#4

Unfortunately, I wasn’t able to find the cause of the issue. I had to use the workaround to make it work. You might want to give that a try. Thankfully for me, the app didn’t have many input fields.


#5

Me too, I am facing same issue with Android 7


#6

I’m also having the same issue :frowning:


#7

Same issue here. Any updates?


#8

Same here after downgrading my app…

Watch here: https://github.com/ionic-team/ionic-plugin-keyboard/issues/307

i’m trying the solutions


#9

Adding uglify-es to devDependencies worked for me:

“devDependencies”: {
"@ionic/app-scripts": “3.1.2”,
“typescript”: “2.4.2”,
“uglify-es”: “3.2.2”
},


#10

yup, Same!

deps:

"@angular/common": "4.4.4",
"@angular/compiler": "4.4.4",
"@angular/compiler-cli": "4.4.4",
"@angular/core": "4.4.4",
"@angular/forms": "4.4.4",
"@angular/http": "4.4.4",
"@angular/platform-browser": "4.4.4",
"@angular/platform-browser-dynamic": "4.4.4",
"ionic-angular": "3.8.0",

 "devDependencies": {
    "@ionic/app-scripts": "3.0.1",
    "typescript": "2.3.4",
    "uglify-es": "3.2.2"
  },