Jarsigner: unable to open jar file: app-release-unsigned.apk

#1

I get this error when I try to sign my .ap

jarsigner: unable to open jar file: app-release-unsigned.apk

I’m using:

jarsigner -verbose -sigalg SHA1withRSA -digestalg SHA1 -keystore my-release-key.jks app-release-unsigned.apk my-alias

I’m sure I’m using the right passphrase, password and alias because I experimented using the wrong ones and I get appropriate errors.

Edit:

I’m following the ionic tutorial https://ionicframework.com/docs/intro/deploying/

In my path “platforms\android\build\outputs” only has android-armv7-release-unsigned.apk and android-x86-release-unsigned.apk

#2

I fixed it with the:

<preference name="xwalkMultipleApk" value="false" /> 

on config.xml

#3

That didn’t help.i am still getting the same error i followed the same link

#4

@mathewk check if this file exists “android-release-unsigned.apk” in this folder platforms\android\build\outputs\apk

If it’s there, go back to root repository and run this command:

jarsigner -verbose -sigalg SHA1withRSA -digestalg SHA1 -keystore MY-ALIAS-release-key.jks ./platforms/android/build/outputs/apk/android-release-unsigned.apk MY-ALIAS

#5

Thank you for your response.it worked…:grinning: