ITMS-90809: Deprecated API Usage - Apple will stop accepting submissions of apps that use UIWebView APIs

I got this mail each submission

Dear Developer,

We identified one or more issues with a recent delivery for your app, “ABCD” 1.0 (1.14). Your delivery was successful, but you may wish to correct the following issues in your next delivery:

ITMS-90809: Deprecated API Usage - Apple will stop accepting submissions of apps that use UIWebView APIs . See http://www.expertsuggestion.com/2019/09/app-store-connect-itms-90809-deprecated.html for more information.

After you???ve corrected the issues, you can use Xcode or Application Loader to upload a new binary to App Store Connect.

Best regards,

The App Store Team

I read your post 100 times you talking about update all version i updated.but when i search after build the keyword UIWEBVIew its founded never gone. i also console in my app its using wkwebview but why apple sending this warning mail.

in the end of post you talking about capacitor . I added in my project and follow all instruction synch my project then making build from android studio for android and x code for ios.then after i submit app again then i got this mail again what happend to ionic team ?

please help i never saw ionic team ,flutter tem,react native team never responding we are developer facing because our app in appstore and i never wanna lose our clients

https://ionicframework.com/blog/understanding-itms-90809-uiwebview-api-deprecation/

bro i irritate from this link ionic team want to prmote there capacitor with 0 plugins support.I am never wanna use capacitor ok so please give diffrent thing.


:slight_smile:

means its take too much time so what will do in this gap to say no to our clients ? because you people not colloborate with apple.and what about your capcitor plugins you many plugins like geolocation are sucked not able to on gps if we manually enable gps then also not able to get location.

@lalitkumarbaghel what are you doing to fix it? Where is your PR?

I replace cordova with capacitor but some plugins is not working correctly.like geolocation its working fine in browser but not in device.

you are not giving me permanent solution you showing only thoughts of apache and ionic team about the warning in blog post from past 2 months.can you please mantion its take how much time ?because i am never wanna loss our clients.