Issues with capacitor run command and capacitor.config.ts file

I am having a few issues with capacitor.

  1. I have created a capacitor.config.ts file, however, each time I run ionic capacitor run ios it creates a new capacitor.config.js file that does not have any of my configuration in it.

  2. On my other machines, I typically get a list of simulator devices to choose from, now I am just getting my Xcode to open and compile. Is there something I need to do to get that list back?

  3. The Pods-App.debug.xcconfig is not writeable by default. It requires me to change permissions on the file. Is this something new?

I recently copied over this project from another machine and I am not sure what’s causing the issues.

Any thoughts?

This is my current environment info:


   Ionic CLI                     : 6.12.3 (/usr/local/lib/node_modules/@ionic/cli)
   Ionic Framework               : @ionic/angular 5.6.11
   @angular-devkit/build-angular : 12.0.5
   @angular-devkit/schematics    : 12.0.5
   @angular/cli                  : 12.0.5
   @ionic/angular-toolkit        : 4.0.0


   Capacitor CLI      : 3.1.1
   @capacitor/android : not installed
   @capacitor/core    : 3.1.1
   @capacitor/ios     : 3.1.1


   cordova-res : 0.15.3
   native-run  : 1.4.0


   NodeJS : v14.17.0 (/Users/<username>/.nvm/versions/node/v14.17.0/bin/node)
   npm    : 6.14.13
   OS     : macOS Big Sur

It looks like I may have solved these issues with a rm ./ios and then running ionic cap add ios again.

Also, update @ionic/cli to 6.16.0 or newer, as before that version Capacitor 3 was not supported