Ios11+xcode9 build fail

Same error here! I’m using the newest xcode

error: exportArchive: "MyApp.app" requires a provisioning profile.

Have you try define the provisioning profile manually in Xcode and then to define it again to automatic? I’ve the feeling that this operation sometimes set back to provisioning profile correctly again, but no warranty that it’ll work

p.s.: could confirm I don’t face this problem, I was able to build my app after having upgraded to Xcode 9

p.p.s.: if that could help, my infos

cli packages:

@ionic/cli-utils  : 1.10.2
ionic (Ionic CLI) : 3.10.3

global packages:

Cordova CLI : 7.0.1 
Gulp CLI    : CLI version 1.2.2 Local version 3.9.1

local packages:

@ionic/app-scripts : 2.1.4
Cordova Platforms  : android 6.2.3 ios 4.5.0
Ionic Framework    : ionic-angular 3.6.1

System:

Android SDK Tools : 26.0.1
ios-deploy        : 1.9.2 
ios-sim           : 5.0.13 
Node              : v8.5.0
npm               : 5.3.0 
OS                : macOS Sierra
Xcode             : Xcode 9.0 Build version 9A235

Also getting the same error. Any help would be appreciated.

And without --release, does it work?

On iOS I never use this. I use it on android only.

For me, simply running cordova build ios fails.

I’m able to build and release an update with Xcode9 and run on ios11.

Xcode9 did loose a lot of my config but opening my xcodeproj file in Xcode and tinkering with things did help.

Despite Xcode showing my signing cert and provisioning profile, I had to uncheck and recheck the little checkbox.

Then Xcode9 requires a 1024x1024 icon now. running ionic resources ios would not generate this, so I made one manually and then opened up Images.xcassets file in my xcode project and dragged the 1024 icon onto the placeholder.

[EDIT]: looks like ionic cli 3.11 fixes this resource issue: Ionic CLI 3.11.0

Built and submitted an update yesterday.

It also build fail without --release

But when I use cordova command line to build release, it fail.

Yes, it can be built at xcode9

An icon so big? Source?

It’s the icon for the App Store listing, you’re suppose to include it on your app bundle now, not upload to itunesconnect - the change was announced at WWDC 17 they say:

https://developer.apple.com/ios/human-interface-guidelines/icons-and-images/app-icon/

1 Like

Thx for finding that!

Look like 3.12.0 solve the icon question:

P.S.: Yep, it creates a 1024x1024 icon and add an entry about it in config.xml

1 Like

I’m watching this PR for Codova-iOS, hopefully it will get fixed soon

1 Like

Try installing the PR mentioned above using:

npm i --save apache/cordova-ios#pull/338/head

Worked for me.

1 Like

Looks like this PR has been merged now.

I am still having this build fail issue even though using the dev version of cordova-ios. Is anyone else still having the same problem?

Cordova’s moving a little bit slow so if you can’t wait on a new cordova-ios release you can try what this person recommends: https://github.com/apache/cordova-ios/commit/cf424b46fb37c00395c1ee9a249280efee5f65b5#commitcomment-24631717

Also have same issue even using the master from their GitHub repo. Did you find a solution yet?

Same here. Solution anybody?

If you’re reffering to the provisioning bug … I got it working like this:

note … I’m in a development team, so I used “developmentTeam”.