Ionic Package: build for IOS failing with xcode error


#1

Dear team, I have been using ionic package build ios command for building my ionic ios app (with security profile). It was working fine till yesterday. Suddenly I started getting the error related to xcode

xcode-select: error: tool ‘xcodebuild’ requires Xcode, but active developer directory ‘/Library/Developer/CommandLineTools’ is a command line tools instance

Please help me to resolve the issue. I tried removing and adding the platform. But it is still not not working.

Thanks
Anoop


#2

Please share your views


#3

“Team” is not reachable here, use support at http://ionicframework.com/support#support


#4

I have the same error by typing ionic package.
has anyone found a solution please ? :frowning:


#5

same error here! had it some months ago and was error on ionic. think they are fixing it, hopefully in the next hours.


#6

this is update from status.ionicframework.com

Legacy (Ionic Cloud) package builds for iOS stuck at “queued”
**Resolved - This incident has been resolved. **
Oct 16, 14:15 UTC
**Update - An issue with a third party service has caused a critical outage in our legacy package service for iOS. Our developers are working to get the service back up and running, but the fix might take several days. **

**This outage only affects users of the legacy platform Ionic Cloud (apps.ionic.io). The current platform, Ionic Pro (dashboard.ionicjs.com), is fully operational. Any users interested in help migrating apps from Cloud to Pro can find instructions here: **
https://ionicframework.com/docs/pro/migration/

But it seems to be a different issue. I tried packaging again.But it is still not working


#7

Now the package is getting QUEUEd


#8

Are u still facing issue?


#9

Yes, no changes at all :frowning:


#10

On my end its working again also on legacy version. Can you share the error ?


#11

Got this :

Adding android project...
Creating Cordova project for the Android platform:
	Path: platforms/android
	Package: fr.provexi.visites.clt15
	Name: MyAppName
	Activity: MainActivity
	Android target: android-25
Subproject Path: CordovaLib
Android project created with cordova-android@6.2.3
Error: Source path does not exist: resources/android/icon/drawable-hdpi-icon.png

#12

I had updated CLI to resolve the error in one of the projects and there i am getting the error related to provisioning profile…

Check dependencies
Provisioning profile “*******” doesn’t support the Associated Domains capability.
Code signing is required for product type ‘Application’ in SDK ‘iOS 10.3’

**** ARCHIVE FAILED ****

The following build commands failed:
** Check dependencies**
(1 failure)
Error: Error code 65 for command: xcodebuild with args: -xcconfig,/Users/package/workspace/apps-291aa81f-31/cordova/platforms/ios/cordova/build-debug.xcconfig,-workspace,****.xcworkspace,-scheme,******,-configuration,Debug,-destination,generic/platform=iOS,-archivePath,****.xcarchive,archive,CONFIGURATION_BUILD_DIR=/Users/package/workspace/apps-291aa81f-31/cordova/platforms/ios/build/device,SHARED_PRECOMPS_DIR=/Users/package/workspace/apps-291aa81f-31/cordova/platforms/ios/build/sharedpch

And in the project with old CLI, i am getting error related to resources… I removed and added the ios platform again.also generated the resource files again…but still getting same error…

Source path does not exist: resources/ios/icon/icon-40.png


#13

Can you try this :

  • Install an older IONIC version : npm install -g ionic@3.12.0
  • Remove, then add your platforms : ionic cordova platform rm ios && ionic cordova platform add ios (Same thing for android)

#14

Please edit your post, it is not very readable at the moment.
Use the </> button above the input field to format your code, command line output or error message (select the text first, then click the button or wrap it in ``` manually). Check the preview if it looks better. This will make sure your text is readable and if it recognizes the programming language it also automatically adds code syntax highlighting. Thanks.


#15

in which CLI version, you are able to build the package successfully? can u pls share the details of your ionic info?


#16

(You are aware that ionic package is a service that runs on a remote server and doesn’t use your local CLI version for anything?)


#17

then if the build process is failing for the same version of the project which succeeded 7 days back, it has to be some issue with the service or due to changes done in the service. Am i right?


#18

Most probably, yes. Use the support link that I posted as the first response to your post 2 days ago.


#19

But I have sent many mails to them and not getting any response.


#20

It seems support team is no longer interested in responding to non-pro users