Ios Xcode 8 Apple Mach-O Linker (ld) Error Group in xcode

I am trying to deploy my app to my iphone. But I am getting the following error when building the app to deploy via xcode 8

Apple Mach-O Linker (ld) Error Group
clang: error: linker command failed with exit code 1 (use -v to see invocation)

Anyone know what this is and how to solve it? Don’t know if it is related, but I had to install CocoaPods when installing the phonegap push plugin. When I google it I see CocoaPods being said a lot but can’t find a solution for this. Help would be appreciated.

1 Like

In my case its adding a pod for my app name to xcode linker which doesnt exist. I removed the pod reference from the linker build settings and after everything seems to work fine.

Search for ld with the name of your pod in xcode build settings. One of the tabs, dont remember exactly which one.

@ajhowaboutsales Thanks for you reply. Appreciate it. But can you be a bit more specific? I haven’t had much experience yet in the apple side of ionic.

Open xcode for your project
-> Go to platforms/ios/*.xcodeproj where * is your project name
-> Double click it to open it with Xcode
-> Click on your project in the left panel in xcode, so you see the details like vresion number.
-> Click on the Build Phases tab (under targets, select your project)
-> There will be a Link Binary with Libraries in the list.
-> Click that and search for the pod name with the name of your proejct in the list.
-> Remove it with the -

Click the Play button and it should be ok now.


This seems to be related with installing the push plugin as that was the moment when i had the same problems.

If you remove the ios platforms to update/resintall it with ionic/cordova, you need to redo these steps.

Thanks a Lot. That worked!!


What I was doing wrong I had opened the .xcodeproj file and tried to build it in there. This way it doesnt have acces to the CocoaPods libraries when building, which it needs.

What I had to do (because I added ionic push) is opening the .xcworkspace file (is located in the same folder) and build it in there. That way it has access to the CocoaPods libraries when building.

1 Like

i do step Click that and search for the pod name with the name of your proejct in the list.
but when search with name project
result :

You save me!!! This