iOS Keyboard doesn't type anything for password input


#1

Hello !

I have a problem with a simple

<input type="password">

for iOS (7 & 8). I just can’t type anything in it.

And for all the input, this keyboard always shows up

If you guys have an idea. I don’t have this error when I disable the ionic cordova keyboard plugin, but I know that it’s mandatory to have it.

Thanks

Kai23


#2

Hmm, is that all you have for the markup?

Can you share the code for that view? I just tested the password inputs and it works fine.

  <label class="item item-input">
    <input type="password">
  </label>

#3

Hello ! I really hope that you can help me cause it’s driving me crazy now :smile:

here is the content of auth_signin.html

<ion-content has-header="true" padding="true"  class="content_auth">
<form name="signin_form" novalidate role="form" >
	<div class="list list-inset">
	<label class="item item-input {{errors && errors.user ? 'has-error' :'' }}">
			<i class="icon ion-android-social-user placeholder-icon "></i>
			<input type="email" name="user" ng-model="user" placeholder="Email / Numéro de téléphone">
		</label>
	</div>
	<div class="list list-inset">
		<label class="item item-input {{errors && errors.password ? 'has-error' :'' }}">
			<i class="icon ion-locked placeholder-icon"></i>
			<input type="password" ng-model="password" placeholder="Mot de passe">
		</label>
	</div>

	<div class="row">
		<div class="col">
			<button class="button {{button_class}} button-block" ng-model="button_connect" ng-click="perform_signin(user, password)" ng-bind-html="button_text">
			</button>
		</div>
	</div>
</form>
</ion-content>

But I don’t know if it comes from the code itself or the plugins. I tried everything :

  • Delete platform and readd it
  • Delete all plugins and readd all

Here is the actual list of my plugins :

com.ionic.keyboard 1.0.3 "Keyboard"
me.apla.cordova.app-preferences 0.4.2 "AppPreferences"
org.apache.cordova.console 0.2.11 "Console"
org.apache.cordova.device 0.2.12 "Device"
org.apache.cordova.inappbrowser 0.5.2 "InAppBrowser"
org.apache.cordova.vibration 0.3.11 "Vibration"

#4

It seems to work without the

<div class="list list-inset">[...]</div>

#5

Are you setting focus on your input using javscript? This has some known issues in IOS7 (might still exist in 8). Is it also happening when tapping the input yourself? Any event listeners ontap, onfocus etc that might conflict?

As an extra side note:
Your dynamic classes (like: {{errors && errors.password ? ‘has-error’ :’’ }} ) will not work in certain browsers (namely IE), and you should use ng-class to achieve your desired result.


#6

Thanks for you’re extra note. I will take it in consideration, I’m pretty new to angular.

There is no focus, and it’s also happening when tapping the input. As said just before, removing the list makes it work, but I don’t know if it’s « normal »


#7

I don’t have this experience in my app. You could create a new starter template for sidemenu, and in the playlist page you could add two list items and make the list list-inset, this way you have zero custom code that could interfere. Nice test to see if your input behaves as expected.


#8

I’ve just tried, it seems to work. I don’t get it. Nervermind


#9

I’m willing to take a look at your code this night, to check if I can find something that interferes, I’ll let you know if I found something before I’ll go to sleep so you can see tomorrow directly if I found something :slight_smile: You would have to share your code with me though, maybe send me a private message to discusse this further. Ofcourse this is not an option if you have sensitive app code, still wanted to offer :wink: (GMT+2 here atm, so it’ll take a few hours before I could look into it :wink: probably not in a position to dive into it till 22 pm tonight)