Ios Build Error After Adding and Removing Admob Plugin


#1

All,

I recently tried to ad Admob to my ionic app. I added it incorrectly the first time using cordova, then I just tried to remove it. I then added it using ionic, still couldn’t get it working, so I removed that as well. Now I can build Android from the command line. I just can’t build ios. I get the following error:

Ld build/emulator/ComicWars.app/ComicWars normal i386

cd "/Users/bparr/Documents/Ionic Workspace/ComicWars/platforms/ios"

export IPHONEOS_DEPLOYMENT_TARGET=6.0

export PATH="/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneSimulator.platform/Developer/usr/bin:/Applications/Xcode.app/Contents/Developer/usr/bin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/opt/X11/bin:/Applications/Dev Tools/android-sdk/platform-tools:/Applications/Dev Tools/android-sdk/tools:/usr/local/mongodb/bin"

/Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/clang -arch i386 -isysroot /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/iPhoneSimulator8.1.sdk -L/Users/bparr/Documents/Ionic\ Workspace/ComicWars/platforms/ios/build/emulator -F/Users/bparr/Documents/Ionic\ Workspace/ComicWars/platforms/ios/build/emulator -FComicWars/Plugins/com.google.cordova.admob -filelist /Users/bparr/Documents/Ionic\ Workspace/ComicWars/platforms/ios/build/ComicWars.build/Debug-iphonesimulator/ComicWars.build/Objects-normal/i386/ComicWars.LinkFileList -Xlinker -objc_abi_version -Xlinker 2 -weak_framework CoreFoundation -weak_framework UIKit -weak_framework AVFoundation -weak_framework CoreMedia -weak-lSystem -ObjC -fobjc-arc -fobjc-link-runtime -Xlinker -no_implicit_dylibs -mios-simulator-version-min=6.0 -framework AssetsLibrary /Users/bparr/Documents/Ionic\ Workspace/ComicWars/platforms/ios/build/emulator/libCordova.a -framework CoreGraphics -framework MobileCoreServices -framework CoreLocation -weak_framework SystemConfiguration -Xlinker -dependency_info -Xlinker /Users/bparr/Documents/Ionic\ Workspace/ComicWars/platforms/ios/build/ComicWars.build/Debug-iphonesimulator/ComicWars.build/Objects-normal/i386/ComicWars_dependency_info.dat -o /Users/bparr/Documents/Ionic\ Workspace/ComicWars/platforms/ios/build/emulator/ComicWars.app/ComicWars

ld: warning: directory not found for option '-FComicWars/Plugins/com.google.cordova.admob'

Undefined symbols for architecture i386:

"_OBJC_CLASS_$_CDVReachability", referenced from:

  objc-class-ref in CDVConnection.o

ld: symbol(s) not found for architecture i386

clang: error: linker command failed with exit code 1 (use -v to see invocation)



** BUILD FAILED **
The following build commands failed:

Ld build/emulator/ComicWars.app/ComicWars normal i386

(1 failure)

Error: /Users/bparr/Documents/Ionic Workspace/ComicWars/platforms/ios/cordova/build: Command failed with exit code 65

at ChildProcess.whenDone (/usr/local/lib/node_modules/cordova/node_modules/cordova-lib/src/cordova/superspawn.js:135:23)

at ChildProcess.emit (events.js:98:17)

at maybeClose (child_process.js:756:16)

at Process.ChildProcess._handle.onexit (child_process.js:823:5)

Any and all help greatly appreciated!
Bruce


#2

Hi there, have you found a fix for this?