Ionic5 app problems on Android 5.1

I am creating an app with latest version of Ionic, that would run on a device with Android 5.1. The problem is that the app doesn’t look correctly once deployed to the actual device:

Left side is how it looks on the browse; right side is how it actually looks on the device (BTW, the Server # input on the device HAS a value, but its not visible for some reason). Any ideas of what the problem may be ?

Regards

Victor Espina

PD-1: Just tried with Capacitor: same problem.
PD-2: The problem is specific to Android 5.1. Just installed the exact same APK on an Android 6 and it runs perfectly.
PD-3: The problem is with icons only, specifically with the outline style. Other issues where scss related and are now solved.

if you’re testing on a simulator or emulated device, it most likely will not have the correct version of chrome needed. They tend to ship with something like chrome 40 or so. What ever the current chrome version was at the time of release.

Real devices are still connected to google play and thus have updated chrome versions, so this is not really an issue.

I would suggest either getting a real device to test against, or just using the latest android releases, which have the latest chrome versions.

Actually, I originally was testing on an emulator with Android 8.1 and everything was working ok… but when my customer installed the app on the actual device, then the problems with colors and icons rised. They sent me some screenshots and videos to show me the problem. After checking the specs of the device (CloverFlex) I realized they were using Android 5.1, and then I decided to test against this version of Android on an emulator, and then I could reproduce all the problems my customer was facing.

So I understand what you say, but my customer device is as updated as it can be and the problem remains. I had to create a different set of icons (ones that actually show ok on Android 5.1) and check the OS version during the app initialization to set the appropriate icons set.