Ionic3 TypeError: Cannot read property 'call' of undefined


#1

My package.json
“dependencies”: {
@angular/common”: “4.1.3”,
@angular/compiler”: “4.1.3”,
@angular/compiler-cli”: “4.1.3”,
@angular/core”: “4.1.3”,
@angular/forms”: “4.1.3”,
@angular/http”: “4.1.3”,
@angular/platform-browser”: “4.1.3”,
@angular/platform-browser-dynamic”: “4.1.3”,
@ionic-native/app-rate”: “^4.3.1”,
@ionic-native/core”: “3.12.1”,
@ionic-native/facebook”: “^4.5.3”,
@ionic-native/file”: “^4.5.2”,
@ionic-native/file-transfer”: “^4.5.2”,
@ionic-native/geolocation”: “^4.3.1”,
@ionic-native/google-plus”: “^4.5.3”,
@ionic-native/native-geocoder”: “^4.3.2”,
@ionic-native/native-storage”: “^4.5.2”,
@ionic-native/network”: “^4.3.1”,
@ionic-native/onesignal”: “^4.5.2”,
@ionic-native/push”: “^4.4.2”,
@ionic-native/social-sharing”: “^4.5.2”,
@ionic-native/splash-screen”: “3.12.1”,
@ionic-native/status-bar”: “^3.12.1”,
@ionic-native/stripe”: “^4.5.2”,
@ionic-native/transfer”: “^3.14.0”,
@ionic/storage”: “^2.0.1”,
“cordova-android”: “^6.3.0”,
“cordova-ios”: “^4.4.0”,
“cordova-plugin-add-swift-support”: “^1.7.0”,
“cordova-plugin-apprate”: “^1.3.0”,
“cordova-plugin-compat”: “^1.2.0”,
“cordova-plugin-device”: “^1.1.7”,
“cordova-plugin-dialogs”: “^1.3.4”,
“cordova-plugin-facebook4”: “^1.9.1”,
“cordova-plugin-file”: “^5.0.0”,
“cordova-plugin-file-transfer”: “^1.7.1”,
“cordova-plugin-geolocation”: “^2.4.3”,
“cordova-plugin-globalization”: “^1.0.9”,
“cordova-plugin-googleplus”: “^5.2.1”,
“cordova-plugin-inappbrowser”: “^1.7.2”,
“cordova-plugin-nativegeocoder”: “^2.0.5”,
“cordova-plugin-nativestorage”: “^2.3.1”,
“cordova-plugin-network-information”: “^1.3.4”,
“cordova-plugin-splashscreen”: “^4.1.0”,
“cordova-plugin-statusbar”: “^2.4.1”,
“cordova-plugin-stripe”: “^1.5.3”,
“cordova-plugin-whitelist”: “^1.3.3”,
“cordova-plugin-x-socialsharing”: “^5.3.2”,
“cordova-sqlite-storage”: “^2.3.0”,
“es6-promise-plugin”: “^4.2.2”,
“ionic-angular”: “^3.9.2”,
“ionic-image-loader”: “^4.2.1”,
“ionic-plugin-keyboard”: “^2.2.1”,
“ionicons”: “3.0.0”,
“moment”: “^2.20.1”,
“rxjs”: “5.4.0”,
“sw-toolbox”: “3.6.0”,
“zone.js”: “0.8.12”
},
“devDependencies”: {
@ionic/app-scripts”: “^3.1.2”,
@types/xml2js”: “^0.4.2”,
“typescript”: “2.3.4”
},

My ionic info

cli packages: (/usr/local/lib/node_modules)

@ionic/cli-utils  : 1.9.2
ionic (Ionic CLI) : 3.9.2

global packages:

Cordova CLI : 7.0.1 

local packages:

@ionic/app-scripts : 3.1.8
Cordova Platforms  : android 6.3.0 ios 4.5.4
Ionic Framework    : ionic-angular 3.9.2

System:

Android SDK Tools : 26.1.1
Node              : v8.11.1
npm               : 5.6.0 
OS                : Linux 4.8

#2

and… where is your code?