Ionic2rc3 build android problem


I’m new with ionic, so hopefully my problem is obvious and easy to solve. I am trying to launch my app with
ionic run android,
and it gives me an error:
Error: Unexpected value ‘DragulaDirective’ declared by the module 'AppModule’
and then fails to build. I have import statements
import { AngularFireModule, AuthProviders, AuthMethods } from ‘angularfire2’;
import { DragulaDirective } from ‘ng2-dragula’;
in my app.module.ts file, and it never complains about the angularfire related functionality, at least not during ionic run.
Here is the full app.module.ts, minus the firebase config info:

import { NgModule } from ‘@angular/core’;
import { IonicApp, IonicModule } from ‘ionic-angular’;
import { MyApp } from ‘./app.component’;
import { HomePage } from ‘…/pages/home/home’;
import { NoteModalPage } from ‘…/pages/note-modal/note-modal’;

import { AngularFireModule, AuthProviders, AuthMethods } from ‘angularfire2’;
import { DragulaDirective } from ‘ng2-dragula’;

declarations: [
imports: [
bootstrap: [IonicApp],
entryComponents: [
providers: []
export class AppModule {}

ionic serve works just fine, including Dragula functionality/typings. I tried ionic run android with a trivial tutorial template app, and it worked fine on my android device.

My environment is:
ordova CLI: 6.4.0
Ionic Framework Version: 2.0.0-rc.3
Ionic CLI Version: 2.1.12
Ionic App Lib Version: 2.1.7
Ionic App Scripts Version: 0.0.46
ios-deploy version: Not installed
ios-sim version: Not installed
OS: Windows 10
Node Version: v6.9.1
Xcode version: Not installed

If typings or other files would help me track down the problem, please let me know, I’ll post them.
Thanks for any help.


OK, so I at least have a workaround. If I change my package.json to have “ionic:build”: “ionic-app-scripts build --dev”, with the --dev flag, I can get my app to run on my android device. I don’t really understand what the implications of that are, although I assume at some point I will want to run the thing without that flag.

I’ve come across all sorts of ngc issues and “fixes” for external libraries, no two of which are the same. Even the Resources page here links to two (distinct?) tactics, one using typings and one using @types for third party libraries. ( I am ignorant enough to be unembarassed that I don’t know how to do a google search for an @ symbol) I’m not really even sure that my problem comes from a type failure.

So my guess is my problem is actually an angular 2 problem that just happened to show up when I run ionic run android. If anyone can point me to current resources to help me understand this better, I would be grateful.

Ionic-app-scripts build fails, ngc failed