Ionic Serve Runtime Error - Cannot read property 'map' of null


#1

Yesterday it was working great… Today, I’m sad…
Can’t found any solution…

FROM DEBUG CONSOLE / BROWSER:
TypeError: Cannot read property ‘map’ of null
at splitDepsDsl (http://localhost:8100/build/vendor.js:9069:17)
at def (http://localhost:8100/build/vendor.js:11052:36)
at directiveDef (http://localhost:8100/build/vendor.js:11009:12)
at View_IonicApp_Host_0 (ng:///IonicModule/IonicApp_Host.ngfactory.js:6:63)
at proxyClass (http://localhost:8100/build/vendor.js:93963:29)
at resolveDefinition (http://localhost:8100/build/vendor.js:9113:17)
at ComponentFactory
.create (http://localhost:8100/build/vendor.js:10216:40)
at ComponentFactoryBoundToModule.create (http://localhost:8100/build/vendor.js:3690:29)
at ApplicationRef_.bootstrap (http://localhost:8100/build/vendor.js:5125:57)
at http://localhost:8100/build/vendor.js:4903:81


#2

Thanks for posting this error message. It is a very great error message.

If you want help getting rid of it, please post a bit what you are doing, what your ionic info output looks like and any other information that might be relevant.


#3

Error Solved… Updated my file package.json “too much”!
After some research, I manually wrote the old versions of peer dependencies needed and voilaaaa… Working again, zero errors! :slight_smile:
Hope my mistake of updating everything can help someone! :blush:


#4

I had a similar error and it appeared ‘suddenly’. I updated all angular packages from 4.4.4 to 4.4.7 and zone.js from 0.8.17 to 0.8.26 and now it works again.